0

I installed ubuntu 12.04 LTS on my Windows 8 laptop following these steps:

  • Created a separate partition in windows (30 GB)
  • Disabled Safe Boot in Bios (Boot Mode is UEFI)
  • Launched ubuntu from the 12.04 LTS Live CD and used the "try" option
  • Launched the installation from within the live CD
  • Selected the 30GB free space and creates a swap partition, then a linux / partition
  • Installed 12.04 on the / partition
  • Restarted the laptop. It was booting on windows 8 only
  • Launched ubuntu from the live CD
  • Downloaded and installed boot-repair
  • Launched Boot-repair and selected the "create a boot info summary"
  • Selected the Recommended Repair option.
  • I got a message saying that EFI was enabled (I want to use EFI). clicked OK.
  • Got a question asking about creating back up files (don't remember exact). I answered yes.
  • After repair was completed I obtained http://paste.ubuntu.com/6835758
    • Reboot

Windows does no longer boot. I get a quick error (cannot read it) a scrambled page and after waiting a while Ubuntu will start.

Regression:

  • I went into BIOS and enabled "Safe Boot" -> same behaviour.
  • Disabled "Safe Boot" again.

I see that in my boot menu I now have a new entry for Ubuntu right after the Windows Boot Manager.

How can I restore my previous Windows boot manager?

0

In your EFI settings (occasionally mistakenly referred to as BIOS) change the default loader to Windows.

  • In my EFI setting (thanks for the correction) Boot menu I have the following: – user241231 Jan 29 '14 at 12:12
  • In the Boot menu I have the following: Boot Mode [EUFI], Secure Boot [Enabled], Boot Priority: 1. Windows Boot Manager, 2. ubuntu, 3. ATAPI CDROM – user241231 Jan 29 '14 at 12:21
  • Strange, have you tried setting Ubuntu to 1? – virtualxtc Jan 30 '14 at 4:21
0

You can try repairing Grub 2 using the command:

update-grub2 

This would update the grub 2 and you might be able to use windows again.

  • I tried this suggestion but I see the same behaviour. The system starts and the Window Boot Manager fails then ubuntu loads without problems. In my boot sequence the Windows Boot Manager is listed before ubuntu. – user241231 Jan 29 '14 at 12:10
  • I also tried update-grub. Same problem – user241231 Jan 29 '14 at 13:46
  • I was able to check the errors displayed during the failing boot. I have the following error: failed to open \EFI\Microsoft\Boot\grubx64.efi, failed to load grub, failed to open \EFI\BOOT\grubx64.efi, failed to load grup. Then there is a pause and the following error is displayed: error: efidisk read error. Then after another pause ubuntu starts. – user241231 Jan 29 '14 at 14:43
  • 1
    I just used the "Restore EFI backups" option of Boot-Repair and went back to booting Windows correctly. I can also boot from ubuntu using the boot menu [F12] but I get a lot of errors before reaching the ubuntu login screen. Very strange but it seems to work. Not sure if there are some problems or risks – user241231 Jan 29 '14 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.