0

I reported this as a bug already (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1272621) but as I think this might be useful to other users, I thought I should ask for a fix here.

I use Ubuntu 13.10 64bits on my Asus F201E, and when I plug in my Acer x233h via VGA as an external monitor, the maximal resolution available in "System settings > Screen Display" is 1024×768 (as well as 800×600), but the maximal resolution of the screen is supposed to be 1920×1080.

I have no proprietary drivers available in "System Setting > Software & Updates > Additional drivers", and I installed the latest version of the Intel Linux Graphics Drivers from https://01.org/linuxgraphics/downloads, thinking it would help (version 1.0.3), to no avail.

This seems it should not be the default behaviour. Any help would be greatly appreciated, as this external monitor ends up having a maximal resolution that is inferior to my tiny laptop... :)

Details about my computer:

DistroRelease: Ubuntu 13.10
Package: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sat Jan 25 16:07:16 2014
DistUpgraded: 2013-10-26 12:01:35,166 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 hdjmod, 1.28, 3.11.0-13-generic, x86_64: installed
 hdjmod, 1.28, 3.11.0-14-generic, x86_64: installed
 hdjmod, 1.28, 3.11.0-15-generic, x86_64: installed
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0106] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:108d]
InstallationDate: Installed on 2013-05-13 (257 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: ASUSTeK COMPUTER INC. X201EP
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=4391c015-75c5-492f-89fd-f37f7d63b00a ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to saucy on 2013-10-26 (91 days ago)
dmi.bios.date: 01/18/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X201EP.208
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X201EP
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX201EP.208:bd01/18/2013:svnASUSTeKCOMPUTERINC.:pnX201EP:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX201EP:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X201EP
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2~saucy1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Sat Jan 25 11:16:25 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12380
 vendor AUO
xserver.version: 2:1.14.5-1ubuntu2~saucy1
5
  • Same problem here, have you tried Gnome? My ubuntu randomly crashes when I connect the external monitor via HDMI. Once I got a kernel panic. There's another person with the same problem on Xubuntu... so maybe it's time to ditch the *buntu family
    – dialex
    Feb 2, 2014 at 18:23
  • I actually use a VGA cable in my case, and I don't get any crash, just a missing resolution. Do you have the same monitor model?
    – stragu
    Feb 3, 2014 at 22:19
  • No, mine is an Asus VW222. I'll try to answer your question.
    – dialex
    Feb 5, 2014 at 9:05
  • 1
    I found my answer in another question. The most upvoted question worked perfectly for me: askubuntu.com/a/226384/29270
    – stragu
    Feb 9, 2014 at 12:15

1 Answer 1

0

About your missing resolution, after you get that problem, try to reboot keeping the monitor connected. Sometimes it works.

If that fails try to close the lid of your laptop with your monitor connected; maybe it'll assume your monitor is now the primary monitor and let you use the full resolution.

Good luck :)

1
  • Thanks for your answer. I tested it but it would not work. Cheers though.
    – stragu
    Feb 9, 2014 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.