I was trying to install dropbox on ubuntu 13.10

My first attempt was to follow the steps from official site:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

Also it installed dropbox, I was not able to see the icon on the panel (I tried this post, but the icon has not appeared). In addition to this, I was not starting automatically and I needed to do ~/.dropbox-dist/dropboxd on each start.

So I uninstalled dropbox with the commands from their website and tried to follow steps described here:

sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5044912E
sudo add-apt-repository "deb http://linux.dropbox.com/ubuntu precise main"
sudo apt-get update && sudo apt-get install nautilus-dropbox

But this resulted in the following error:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: nautilus-dropbox : Depends: dropbox but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Any idea how it should be solved?


4 Answers 4


First of all, you could use deb http://linux.dropbox.com/ubuntu saucy main instead of precise, but since all the "versions" of the repository end up in the same package pool, that ought not to change anything.

Now, to your issue. I'm not sure, but since nautilus-dropbox is a transitional package for dropbox, try installing dropbox directly; it might solve your installation problem.

Step by step

First of all, let's assume you haven't downloaded any package from Dropbox's website.

Enable the repository:

Run these lines from the Terminal.

echo 'deb http://linux.dropbox.com/ubuntu saucy main'>>'dropbox.list'
chmod 644 'dropbox.list'
sudo chown root:root 'dropbox.list'
sudo mv 'dropbox.list' '/etc/apt/sources.list.d/dropbox.list'
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 5044912E

The first line creates a line containing the repository in a file named dropbox.list (note that this uses saucy, but you can use any previous version, as all repos end up in the same package pool). The second and the third give some necessary access and group permissions to the file. The fourth line moves the file to the place all repos are located. Finally, the fifth line adds the Key File so that the repository can be authenticated.

Now, let's install the package:

sudo apt-get update
sudo apt-get install dropbox

Now you can launch Dropbox from the application launcher of your choice.

  • Would you mind giving explicit steps? I tried following @Orion's directions below, but the same error popped up. Mar 12, 2014 at 16:20
  • 2
    @AlexWilliams I hope my edit helps you. Mar 12, 2014 at 16:59
  • 2
    Yeah, installing the "dropbox" package rather than "nautilus-dropbox" is the key. Sep 7, 2014 at 18:10


sudo apt-get autoremove

to remove any broken packages.

sudo apt-get update    
sudo apt-get upgrade    
sudo apt-get remove dropbox    
sudo apt-get install dropbox

Now try installing

sudo apt-get install nautilus-dropbox

Sometimes the dropbox app gets a broken package and you have to do an update and upgrade and if it is held back, just remove and then install it to fix it.

This is how I fix most broken package issues in GNU/Linux with apt.

  • 1
    This didn't help me. I am still getting the same error. May 6, 2017 at 12:43

I was having a similar issue on 14.04. Although Dropbox was running at the background, I was unable to see the Icon on the task bar. I needed this for the Selective Sync in particular. I tried several things from reinstalling Dropbox to using the .deb files.

After various attempts this has worked:

  • Install the cloud synchronisation CLI and Nautilus extension for dropbox from the Software Centre. Check to include Python-gpgme in the additional add-ons.
  • Then install the Dropbox from Software Centre. It will ask you to remove the CLI Nautilus, choose to install anyway. This one and the above both appears if you search for dropbox.

  • During the installation, it will ask you first to start dropbox, and then to restart Nautilus. In my case, when I made those choices, those pop-up windows didn't close automatically.

After the installation is completed, I was able to see the Dropbox icon on my task bar. Great! After allowing it sometime to download the folder list, I could do the Selective Sync as well.

Note that I removed/purged all Dropbox related stuff before doing this. And not sure if it had any effect, but had done this before.

sudo apt-get update && upgrade


sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0

I had the same problem. My solution was: Uninstall the existing Dropbox client from the Ubuntu Software Center and install the client version from the Dropbox website ( https://www.dropbox.com/install ).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .