0

My title may be incorrect, but I hope I get the idea across...

You know, when you have a failed startup and Grub decides next time it starts up it'll disable the countdown and give you indefinite time to choose your OS? I dont want that.

I have a computer that needs to run 24/7, and has a failsafe that'll restart the computer under some circumstances. This weekend, while I was out of town, I had the computer restart twice-- interrupting the first boot! This disabled the countdown, so the computer sat there in the Grub screen all weekend- which wasn't good, for me.

1
0

My grub is hidden, but it boots everytime without asking. Here is my /etc/default/grub :

GRUB_DEFAULT=0

GRUB_TIMEOUT=0

GRUB_SAVEDEFAULT=true

GRUB_HIDDEN_TIMEOUT=0

GRUB_HIDDEN_TIMEOUT_QUIET=true

This will boot the first entry everytime, without asking. I'm not sure it's recommended if you need to access recovery (but personnaly I have disabled recovery, so...)

2
  • Recovery would be nice. I just want to stop it from not counting down on a failed boot. – Thomas-George Miller Jan 27 '14 at 19:59
  • Well, with my answer, recovery would still be there, but I'm not sure how to access it... maybe with a way to un-hide timeout with a key like Shift, but I never managed to make it work. I just chroot my system whenever a problem comes (lazy as ****, I know^^) – MrVaykadji Jan 27 '14 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.