But just LightDM. It worked this morning, just does not seem to be working this evening. This seems to occurred after a shutdown after a wakeup from hibernation. I always get a password denied sort of thing:

enter image description here

I can login into Gnome by running this in the tty (which I can access):

sudo service lightdm stop
sudo service gdm start

and KDE as well (when installed), and using sudo service kdm start instead of the latter command.

Xfce also works.

To resolve this I have tried:

  • Removed ~/.Xauthority - to no effect
  • Rebooting
  • Changed password 5/6 times - may eventually get very annoyed and purge /etc/passwd and restore from backups
  • Reinstalled Unity and LightDM - no effect
  • Purged and Reinstalled ALL Desktops and Desktop Managers
  • reconfigured LigthDM with dpkg-reconfigure - useless as it was done by the above and only sets the default desktop manager.
  • Created a different user, that does not work - the same for the 'Guest Session'
  • purged all recent installs

Here is `/etc/lightdm/lightdm.conf:


And here is /var/log/lightdm/x-0-greeter.log. This is from the recent login, where I tried to login with the user test, and then my default login, wmobbs.

If anything more relevant to user/lightdm settings is available, ask and I'll post it.

Nothing appears to be a problem in .xsession-errors. Yes, there are previous questions like this and this, but those did not help in anyway.

All to no effect :-(

Using Ubuntu 13.10, Intel i5 Lenovo G570 (integrated graphics, with Radeon HD 6370M discrete graphics - but I don't think this is the problem) laptop.

I can still use the machine, I only really use it for work and stuff. I hope to solve this myself, but this will be useful if anyone can think of any ideas.

  • 1
    Look in the logs: /var/log/lightdm/lightdm.log and /var/log/lightdm/x-0-greeter.log. You also didn't try (or you didn't write you did) reinstalling/reconfiguring the unity-greeter.
    – falconer
    Jan 27, 2014 at 17:38
  • @falconer - unity-greeter went as a dependency, I removed all of LightDM as well as Unity, Gnome, KDE, even if it was not installed, I tried to apt-get purge it. I have checked the log, and added it.
    – Wilf
    Jan 27, 2014 at 17:45
  • @falconer - added log, added picture :-(
    – Wilf
    Jan 27, 2014 at 18:09
  • Found part of the problem - lightdm cannot be stopped, therefore cannot be 'purged'...
    – Wilf
    Jan 27, 2014 at 19:52
  • Then just SIGKILL it. killall -SIGKILL lightdm . The greeter log doesn't show much about the problem for me. Try looking in the /var/log/auth.log.
    – falconer
    Jan 27, 2014 at 19:57

4 Answers 4


Have you ever tried to delete everything in /etc/lightdm/lightdm.conf ?

To do this open a terminal with Ctrl+Alt+t and type the following command :

sudo nano /etc/lightdm/lightdm.conf

then delete everything in it, save it and reboot by typing :

sudo reboot

It solved my problem many times ago.

Have a nice day.

  • Purging and reinstalling should of solved that, I checked, and it removed the relevant config files.
    – Wilf
    Jan 27, 2014 at 17:43
  • Use ctrl+alt+F1 to enter the shell. Jul 20, 2022 at 18:52

Note: messing around with keyboard layouts as well might of helped. For other people with the issue you could also used another login manager - e.g. gdm (Gnome Display Manager)

Seems sorted now... I think. I rebooted and purged one or two more things.

I managed to stop lightdm from running on boot as explained here, stopped all lightdm user processes with pkill -U lightdm. I could then purge lighdm and other slightly relevant stuff with various incantations of:

sudo apt-get purge ...

I also made sure that the lightdm user was removed, which seem to be why I could not fully remove it.

I just spotted when it removed the extra pieces of the kernel (the kernel it was using - how did it do that?), including the bits with internet + graphics drivers. I then resolved that, and rebooted. This method probably is not recommended for anyone else with this problem.


I had a similar issue. For me,


was not executable. Making this file executable solved it:

sudo chmod +x /etc/X11/Xsession

Source: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=748944#27

  • Please explain how to make that file executable as new users may not know what you are talking about.
    – user484158
    Jun 4, 2016 at 15:07

I used gdm3 instead as Lightdm was unable to change password

Purging and reinstalling may help

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .