2

I've copied one disk content to another disk and now when system boots I get this:

resume: libgcrypt version: 1.5.0
resume: Could not stat the resume device file '/dev/sda6' please type in full path name to try again or press ENTER to boot the system

The problem is now i don't have /dev/sda6. I removed this row from fstab, restarted system but I still get this message.

1 Answer 1

6

In addition to fstab, you also need to remove the disk from the boot process.

There are two things to check:

  • uswsusp.conf - if there's any line like resume /dev/sda7 there, comment it out.

  • initramfs - update it with update-initramfs -u -k all

3
  • Jenny thanks for this awesome answer. A lot of fixes for this same problem just list update-initramfs -u as the solution. However your command fixed my problem when I realized that -k all updates all images for versions of kernels known to initramfs. Thanks :)
    – benathon
    Jan 3, 2016 at 4:22
  • @portforwardpodcast I'm glad it helped!
    – Jenny D
    Jan 3, 2016 at 10:19
  • perfect! what worked here was to comment a line at uswsusp.conf pointing to a valid LVM swap (there seems to have some incompatibility between them), and well... I am on a desktop anyway.. thx! Jul 2, 2017 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.