I'm running Ubuntu 13.04 and have pgadmin3 1.16 installed.

I downloaded pgadmin3-1.18.1.tar.gz from http://www.postgresql.org/ftp/pgadmin3/release/v1.18.1/src/

I followed all the instructions found in the INSTALL file and make install seemed to work well. the problem is that when I try to run pgadmin3, it still opens 1.16.

I tried uninstalling 1.16 and then reinstalling 1.18, but then I can't even find the executable.

my guess is that 1.18 is installed, how/where can I find it? or if not, how do I upgrade 1.16 to 1.18



the commands I ran are:

  1. taken from How can I update pgadmin3 to v1.14? and http://linuxrails.blogspot.co.il/2012/09/install-pgadmin-for-postgresql-92-on.html

    • sudo apt-get remove pgadmin3
    • sudo apt-add-repository ppa:voronov84/andreyv
    • sudo apt-get update
    • sudo apt-get install pgadmin3
  2. from pgadmin3-1.18.1/INSTALL

    • sudo apt-get remove pgadmin3
    • tar xvfz pgadmin3-1.18.1.tar.gz
    • cd pgadmin3-1.18.1
    • ./configure
    • make all
    • sudo make install
  • It would be great if you show us ever single command that you've entered. Check the bash history: ~/.bash_history – Lucio Jan 27 '14 at 15:32
  • none of the commands I ran show in this file :( – avital Jan 27 '14 at 15:53
  • Oh, that means that you entered a lot of commands. Don't worry, is very common. – Lucio Jan 27 '14 at 15:56
  • I added the 2 sets of commands I ran to the question above. – avital Jan 27 '14 at 15:59
  • edit your question and include type pgadmin3 – Braiam Jan 27 '14 at 16:01

Add following line to /etc/apt/sources.list:

deb http://apt.postgresql.org/pub/repos/apt/ precise-pgdg main

Then run:

sudo apt-get update
sudo apt-get install pgadmin3
  • first of all thanks! just thought to let you know that apt-get update throws: W: GPG error...: NO_PUBKEY 7FCC7D46ACCC4CF8 after adding this line. had to fix it locally. – avital Mar 30 '14 at 11:16

You need to add the key first using the following command. (The command downloads the key from the postgresql.org server and passes it to the apt-key command via a pipe)

 wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc|sudo apt-key add -

See http://www.ubuntuupdates.org/ppa/postgresql


To upgrade Postgres SQL on Ubuntu the correct command is

sudo apt-get update
sudo apt-get upgrade pgadmin3

Given that Postgres is already installed,

sudo apt-get upgrade pgadmin3

would return that pgadmin is already installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.