I am running Ubuntu 13.10 on my PC with 2x Sapphire Radeon HD 7950. After I installed fglrx, ran sudo aticonfig --adapter=all --initial and rebooted, I get a black screen.

When I go into recovery mode and run fglrxinfo, it gives me the following output: unable to open display (null)

When I looked on the ubuntu forums someone suggested I run aticonfig --acpi-services=off but unfortunately this doesnt seem to have any effect.

I should also mention that I previously had an install with fglrx on this system which worked fine. At some point this black screen appeared. After that I decided to reinstall Ubuntu, which works fine until I install fglrx again.

Does anyone have some suggestion? Any help would be appreciated, and I would be happy to provide more information if needed.

Thanks in advance!


The only way to get out of there is to get out of this situation is to get to a recovery console.

Hold Shift key on boot up.

Once you are on the GRUB menu, choose a recovery mode. Then, choose a root console.

Once you manage to get to a recovery console as root:

apt-get autoremove fglrx
|improve this answer|||||
  • and if you are switching back to open source drivers, remember to remove /etc/X11/xorg.conf, otherwise it will not work. askubuntu.com/a/401955/16395 – Rmano Jan 27 '14 at 15:32
  • So does this mean there is no way for me to use fglrx? Like I stated above, I used fglrx before with success but somehow it doesnt work anymore. – jaspervdmaarel Jan 27 '14 at 15:35
  • It's very difficult to answer this, because we cannot know if the issue is fglrx, or the configuration of fglrx. You may try to add "nomodeset" following "quiet splash" in the configuration file /etc/default/grub (the complete line should be GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"), Then sudo update-grub. – cochisebt Jan 27 '14 at 16:04

A BLACK screen is the result of a normal Catalyst install from the Vendor with Ubuntu 13+. I have incorporated the patch into the Knary (sourceforge) https://sourceforge.net/p/knary/discussion/general/thread/2ad755b9/?limit=25#1b3c AMD installation. But here it is for those interested in manually applying.

-- Download the catalyst 13.12 into any directory. Create this file...Here is a cat command to do this...

cat > 1310patch <<EOF
 <     if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
 < #else
 <     tbl_size = 0x7fffffff;
 <     if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
 < #endif
 <     {
 <         return KCL_ACPI_ERROR;
 <     }    
 <     ((acpi_table_handler)handler)(hdr);
 <     return KCL_ACPI_OK;
 < }
 >     #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,3)    
 >         if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
 >     #else
 >         tbl_size = 0x7fffffff;
 >         if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
 >     #endif
 >         {
 >             return KCL_ACPI_ERROR;
 >         }
 >         ((acpi_tbl_table_handler)handler)(hdr);
 >     #else
 >         ((acpi_table_handler)handler)(hdr);
 >     #endif
 >         return KCL_ACPI_OK;
 >     }

-- Run this Code which will backup, then patch the cat module as shown...

sudo apt-get install dpkg-dev debhelper dh-modaliases execstack dkms
sudo chmod a+x amd-catalyst-13.12-linux-x86.x86_64.run
sudo ./amd-catalyst-13.12-linux-x86.x86_64.run --extract 1310patch
MYsave=date +%B%d%Y%H%M%S
sudo cp 1310patch/common/lib/modules/fglrx/build_mod/kcl_acpi.c 1310patch/common /lib/modules/fglrx/build_mod/kcl_acpi.c.${MYsave}
sudo patch -i ./1310patch 1310patch/common/lib/modules/fglrx/build_mod/kcl_acpi.c
cd 1310patch
sudo./ati-installer.sh 13.251 --buildpkg Ubuntu/saucy

-- now install the packages as the compiled correctly -- install the resulting packages in order is best

sudo dpkg -i fglrx_
sudo dpkg -i fglrx-dev
sudo dpkg -i fglrx-a*

-- catch all

sudo dpkg -i *.deb

FORCE Uninstall

BLACK screen --

Ctrl+Alt+F1 ...Login...
sudo /usr/share/ati/amd-uninstall.sh --force
sudo /usr/share/ati/fglrx-uninstall.sh --force
sudo reboot


|improve this answer|||||

i have gone through same problem and tried every thread but of no use.finally this worked hope it works for others too. start the computer when black screen comes press- ctrl+alt+f1 after that it will ask for log in & password,then type- # sudo -i to enter in root command and lastly type-# apt-get remove --purge fglrx after its done type-# shutdown -r now to shutdown.restart and you are done.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.