0

When i start my Ubuntu (i have only Ubuntu, no other OS- Lenevo B560)the start screen displays this message. I have version 12.04, but initially when i install this there is no such message, but after downloading updates i got this message.The message is like below:-

the Disk driver for /dev/mapper/cryptswap1 is not ready yet or not present.

continue to wait, or press S to skip mounting or M for manual recovery.

So it takes some more time to boot. I am a basic user having no knowledge about command lines. So please be slight not technical or exact step by step description

1

This error message indicates that the the system was unable to use its encrypted swap partition.

Not being able to use swap may cause slowdown, especially if your machine doesn't have much RAM installed.

Assuming the system is booting, you should be able to fix the problem without too much hassle.

Step by step

  1. Boot and open a terminal (ctrl+alt+t)
  2. Run this command sudo gedit /etc/fstab, a new window with the text editor should appear.
  3. Change the line /dev/mapper/cryptswap1 none swap sw 0 0 to read /dev/mapper/cryptswap1 none swap sw,noauto 0 0
  4. Save
  5. Back in the terminal run sudo gedit /etc/rc.local and add these two lines right after exit 0:

    sleep 5
    swapon /dev/mapper/cryptswap1
    

I hope this fixes your problem, good luck.

  • 1
    Thank You, Minnen, This was my first Question and i solved it with help from you. Sorry for delay in thanks giving as i have incorporated your suggestion now and its working – Auro_user239244 Feb 1 '14 at 11:10
  • Im glad it solved your problem, pleas close the question by marking my answer as the solution – Minnen Feb 2 '14 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.