I have an old install of Backtrack 5 amd64 and yesterday i tried to upgrade it. For some reason that upgrade failed and i cannot manage to get it working. So I now want to copy my data from some file locations to an external hard disk in order to perform afterwards a clean install with ubuntu. I booted a live usb with ubuntu and i am able to see the files within the file explorer. However some of the i cannot copy i.e. do not have sufficient permissions.

Provided I know the root password of my original backtrack installation How can i mount it using this password from the ubuntu live cd so that i can do any file operations with granted permisions???

What I ve already done:

  1. Booted the Ubuntu Live CD.
    1. Pressed Ctrl-Alt-F1
    2. sudo mount /dev/sda1 /mnt
    3. sudo chroot /mnt
    4. Pressed Ctrl-Alt-F7
    5. Clicked on try ubuntu
    6. I can now copy some files but not all of them.

Thanks in advance!


What you could try is start Nautilus as root and then copy the files. To start Nautilus as root, enter in terminal:

gksu nautilus
  • 1
    worked like a charm :D – Harry Jan 27 '14 at 13:07
  • if you copied the files to an ext filesystem, the files' access rights and ownership will be changed to root.. so you might have to change to your normal user.. you could do it using commands in terminal or open nautilus with root rights, right-click files to change the files and from the menu choose Properties -> Permissions to change them graphically... – precise Jan 27 '14 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.