3

I got this when i check my postfix logs everything was alright i didnt make any changes in my server just some iptables now when i send an text email everything is ok and the status of email is sent the problem when i send an email with any hyperlink my dsn=5.0.0 bounced 550 Action not taken.

Postfix log error

Jan 26 15:58:31 mail postfix/smtp[2075]: D4B1024C21: to=<stimpack47@aol.fr>, relay=mailin-02.mx.aol.com[64.12.137.162]:25, delay=0.62, delays=0.1/0.01/0.32/0.2, dsn=5.0.0, status=bounced (host mailin-02.mx.aol.com[64.12.137.162] said: 550 Action not taken (in reply to end of DATA command))

Jan 26 15:58:31 mail postfix/cleanup[2068]: 6DA6C257FB: message-id=<20140126205831.6DA6C257FB@mail.mediatoolsbox.us>

here is my config of postfix

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
header_checks = regexp:/etc/postfix/header_checks
home_mailbox = Maildir/
html_directory = no
inet_protocols = all
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
milter_default_action = accept
milter_protocol = 2
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mydomain = mydomain.co
myhostname = mail.mydomain.co
mynetworks = 127.0.0.0/8, myip
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
non_smtpd_milters = $smtpd_milters
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)
smtpd_milters = inet:127.0.0.1:8891
unknown_local_recipient_reject_code = 550
virtual_transport = dovecot

master.cf output

# ==========================================================================
smtp      inet  n       -       n       -       -       smtpd
#submission inet n       -       n       -       -       smtpd
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#smtps     inet  n       -       n       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#628      inet  n       -       n       -       -       qmqpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       n       -       -       smtp

any suggestions?

  • can you add the complete files /etc/postfix/master.cf and /etc/postfix/main.cf Would also be helpful if you added the complete dsn feedback\error and log entries from postfix. – Anders F. U. Kiær Jan 27 '14 at 23:01
  • i have provided master.cf and error log what do u thing? – Omer Stimpack Jan 29 '14 at 23:57
  • Have you checked you server against any blacklist? E.g. mxtoolbox.com/blacklists.aspx – Anders F. U. Kiær Jan 30 '14 at 1:02
  • Posted a answer, hopefully it can enlighten your issue a bit more. – Anders F. U. Kiær Jan 31 '14 at 0:20
1

Have you checked you server against any blacklist? E.g. mxtoolbox

The reason for asking, is that i can't see any client restrictions for your server. Implying that it might have ran as an semi open relay, that will easily get you blacklisted.

To get a bounce after you have transmitted data, is a common way to throttle spam senders. So the error is possible caused by the hyperlink to trig the spam threshold at the receiving server.

Spam thresholds is often a measurement made different from every organization running a service. It exist some golden rules that will make it easier to get content through.

Feel free to improve, or comment : )

  • This is an old question, but since I'm having the same issue: you're saying that that error, "550 Action not taken (in reply to end of DATA command)", means that data was tranmitted and then dropped? And that's why it seems certain that the problem is being caused once the email has left the server? – felwithe Aug 20 '18 at 3:25
  • In other words: the receiving part(eg. a server or mitm) successfully received the data and decided to raise an error (550 action not taken), and most likely based on content decided to stopp processing the message. Just dropping the message with an error instead of confirming that it received the keyword for end of transfer data / email. – Anders F. U. Kiær Aug 22 '18 at 13:34
1

In a case I recently encountered, it was a Man In The Middle box put in place by a sender's hosting provider. It was programmed to inspect all port 25 traffic and if it saw a couple of strings from an old, expired Spamcop report, it would drop the connection at end of DATA, with the sender getting the "550 Action not taken" message.

No other email from the sender was affected.

Pretty sleazy.

0

Michael's MITM mail scanner answer above helped me.

I'm not sure if it is the webhost, our ISP, or possibly our firewall, but something was preventing seemingly random Word doc and docx attachments from our website running on a VPS to the office.

Turning on STARTTLS on this email routing "fixed" the issue (the web server and the destination email domains were the same, so there was an overlooked setting to turn this on). The hint was that the same emails going to Google did work, and this used encryption. The encryption prevents whatever was snooping on the email from doing it's thing.

Or maybe I stumbled on a bizarre bug between hMailServer and postfix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.