Just installed Ubuntu 13.10, I tried to connect wireless but It didn't detect any network. This is what happens when I check my wireless:

:~$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no

I've tried with the command:

-rfkill unblock 0

but I guess is only for soft blocks, because don't works after reboot...

How could I fix it this?

I let you check the information about my network card and kernel. The version of ubuntu is in spanish, sorry.

:~$ sudo lshw -c network
[sudo] password for : 
  *-network DESACTIVADO   
       descripción: Interfaz inalámbrica
       producto: AR9485 Wireless Network Adapter
       fabricante: Qualcomm Atheros
       id físico: 0
       información del bus: pci@0000:03:00.0
       nombre lógico: wlan0
       versión: 01
       serie: 24:0a:64:14:77:bf
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuración: broadcast=yes driver=ath9k driverversion=3.11.0-15-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       recursos: irq:17 memoria:f7900000-f797ffff memoria:f7980000-f798ffff
  *-network
       descripción: Ethernet interface
       producto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       id físico: 0.2
       información del bus: pci@0000:04:00.2
       nombre lógico: eth0
       versión: 0a
       serie: ac:22:0b:09:91:b2
       tamaño: 100Mbit/s
       capacidad: 1Gbit/s
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuración: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-1_0.0.3 06/18/12 ip=192.168.1.106 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:45 ioport:d000(size=256) memoria:f2104000-f2104fff memoria:f2100000-f2103fff

Furthermore I want to say that this same problem happened with the last versions of Linux Mint (15 and 16).

P.S: I've looked everywhere on this forum but I haven't found solution.

As you stated, it's obviously the hardware switch causing this issue.

0: phy0: Wireless LAN
     Soft blocked: no
     Hard blocked: yes

So my advise would be:

  • Try to press [Fn] + ((i))

    where Fn is the hardware switch key on laptop keyboards
    and ((i)) one of the [F1]-[F12] keys for the wireless device.
  • Try to disable your wireless card in your BIOS, reboot your machine and re-enable the device again.
  • Finnally check if the hard block is gone.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.