3

Just installed Ubuntu 13.10, I tried to connect wireless but It didn't detect any network. This is what happens when I check my wireless:

:~$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no

I've tried with the command:

-rfkill unblock 0

but I guess it's only for soft blocks, because it doeswn't work after rebooting.

Information about network card and kernel:

:~$ sudo lshw -c network
[sudo] password for : 
  *-network DESACTIVADO   
       description: Wireless interface
       product: AR9485 Wireless Network Adapter
       vendore: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       series: 24:0a:64:14:77:bf
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.11.0-15-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f7900000-f797ffff memory:f7980000-f798ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.2
       bus info: pci@0000:04:00.2
       logical name: eth0
       version: 0a
       series: ac:22:0b:09:91:b2
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-1_0.0.3 06/18/12 ip=192.168.1.106 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       recursos: irq:45 ioport:d000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff

This same problem happened with the latest versions of Linux Mint 15 and 16.

1

As you stated, it's obviously the hardware switch causing this issue.

0: phy0: Wireless LAN
     Soft blocked: no
     Hard blocked: **yes**

So my advice would be:

  • Try pressing Fn + ((i))

    where Fn is the hardware switch key on laptop keyboards
    and ((i)) one of the [F1]-[F12] keys for the wireless device.

  • Try disabling your wireless card in your BIOS, reboot your machine and re-enable the device again.

  • Finally check if the hard block is gone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.