I tried to use my Virtual Box and this is the error I received - (I just updated to the new Ubuntu also) and I am VERY new at this Linux OS.

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Virtualbox Kernel driver not installed

24 Answers 24

Most probably all you have to do is run

sudo apt-get install dkms

(or install dkms from the software center)

and then run

sudo /etc/init.d/vboxdrv setup

and write your password.

if you have any error with this commands use this one

sudo modprobe vboxdrv
  • 35
    vboxdrv doesn't exist. – weberc2 Jan 10 '13 at 23:01
  • 1
    @weberc2 VirtualBox OSE from Ubuntu repo doesn't have it, the virtualbox.org version does have it. $ dpkg -S /etc/init.d/vboxdrv virtualbox-4.2: /etc/init.d/vboxdrv – gertvdijk Jan 10 '13 at 23:19
  • 1
    @gertvdijk gotcha. I'm going to try some of the other answers in this question first, but failing that I'll use the one from virtualbox.org. Why are so many of the apps in the Ubuntu repo are crippled when the generic versions are not? /rant – weberc2 Jan 10 '13 at 23:44
  • 2
    Too bad I have to run after every reboot :-/ Is there a more permanent solution? Or is this actually supposed to be permanent, and I have another problem? – Nicolas Raoul Aug 7 '15 at 2:41
  • 2
    sudo: /etc/init.d/vboxdrv: command not found – Aaron Franke Apr 15 at 22:16

Re-install virtualbox-dkms package first

sudo apt-get autoremove virtualbox-dkms
sudo apt-get install build-essential linux-headers-`uname -r` dkms virtualbox-dkms

After that You can enable it manually

sudo modprobe vboxdrv
sudo modprobe vboxnetflt
  • 11
    sudo modprobe vboxnetflt results in FATAL: Module vboxnetflt not found. same for vboxdrv – weberc2 Jan 10 '13 at 23:38
  • 2
    Also, when installing virtualbox-dkms, I get non-error output like this: Module build for the currently running kernel was skipped since the kernel source for this kernel does not seem to be installed. – weberc2 Jan 10 '13 at 23:39
  • 1
    Thanks just doing this solved it for me: sudo apt-get remove virtualbox-dkms / sudo apt-get install virtualbox-dkms – David Sep 18 '13 at 20:15
  • On 13.10, with virtualbox-qt package installed this was the best solution for me, but with sudo apt-get install dkms virtualbox-dkms. Those packages installed the modules automatically, no other command was necessary. – Nathan Kidd Mar 8 '14 at 15:55
  • 3
    On 14.04 this also worked for me. It's important to make sure you install the headers for your kernel (see @Husni's answer) before reinstalling virtualbox-dkms, or the modules will not be built. – adelphus Mar 19 '15 at 16:17

here is solution which works for me on 12.10:

  1. Install the latest version of virtualbox according your architecture and distribution version from https://www.virtualbox.org/wiki/Linux_Downloads

  2. run sudo apt-get install build-essential linux-headers-`uname -r`

  3. run sudo /etc/init.d/vboxdrv setup

Last two steps quoted from one of the comments to the bug on the same theme - https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1016165

On 12.10, these solutions all failed for me. However the following worked:

  1. Run command:

    sudo gedit /etc/apt/sources.list.d/vbox.list
    

    and paste in this line, then save:

    deb http://download.virtualbox.org/virtualbox/debian quantal contrib
    
  2. Run:

    sudo apt-get update && sudo apt-get -y upgrade
    

    to update your machine to the latest

  3. Run:

    sudo apt-get remove virtualbox
    

    Then install Oracle's version:

    sudo apt-get install virtualbox-4.3
    

Should work now. Don't forget to download the extension pack from http://www.virtualbox.org as well.

  • I'm running 12.10 64bit and this worked for me. – greg Apr 1 '13 at 6:59
  • 13.04 and works! – asymptotically Jul 15 '13 at 18:09
  • 1
    14.04 - works fine. – 0x8BADF00D Oct 24 '14 at 1:31
  • 14.10 - Worked for me, I just had to write deb http://download.virtualbox.org/virtualbox/debian trusty contrib instead. – Mahdi Jan 18 '15 at 14:46

In Ubuntu 14.04, 64 bit, what worked for me is

sudo dpkg-reconfigure virtualbox-dkms
  • 2
    This yeilds (for me): No suitable module for running kernel found. See Bug 1457776. – Lonnie Best Sep 22 '15 at 19:11
  • 1
    On 2015.04: dpkg-query: package 'virtualbox-dkms' is not installed and no information is available – Nicolas Raoul Nov 17 '15 at 5:08

I have deb http://download.virtualbox.org/virtualbox/debian precise contrib in my /etc/apt/sources.list, to be able to use Virtualbox 5.x.

Faced with the same error, I tried all of the methods here and none work but this (bandwith-wasting) one:

  1. sudo apt-get purge virtualbox virtualbox-4* virtualbox-5*
  2. Reboot
  3. sudo apt-get install virtualbox-5.0
  4. Install the latest extension pack from https://www.virtualbox.org/wiki/Downloads

Another reason why this can happen is that you have an older GCC version (like I had GCC 4.8 installed on Ubuntu 16.04) set as default (by, for example, using update-alternatives) when you try to update or reinstall VirtualBox.

Just go back to default GCC version that came with your distro for VirtualBox installation, and it'll work fine.

You can then switch back to an older GCC version after VirtualBox is installed.

I have the same issue and solved by these two steps:

sudo apt-get install linux-headers-`uname -r`

then

/etc/init.d/vboxdrv setup
  • 7
    On 2015.04: /etc/init.d/vboxdrv: No such file or directory – Nicolas Raoul Nov 17 '15 at 5:08
sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove --purge virtualbox-dkms
sudo apt-get install virtualbox-dkms

Just use three command for ubuntu users.

  • 1
    Why these command may help? – Pilot6 Jan 27 '17 at 9:07
  • Because I had almost same error and worked for me. – jsroyal Jan 27 '17 at 10:05
  • 1
    jsyroyal, what @Pilot6 is asking you is, what do those commands do? why do they work? You should probably edit your question to include information on what those command do. Cheers . – Tshilidzi Mudau Jan 27 '17 at 10:12

Took me a long time to solve this issue. Had this problem with vBox across 2 distros (Ubuntu and Arch).

I had dkms and all the modules already installed and compiled into my kernel, yet I still got a module related error message when I tried to run a vBox virtual machine.

If your vBox GUI starts without a hitch but get an error telling to install the VBoxDrv kernel module when you try to run a virtual machine, your problems are not related to installing the modules into your kernel but ACTIVATING THEM in modprobe which the module installation script fails to do.

To load a module manually (such as vboxdrv in your case), open a terminal prompt and put in :

sudo modprobe vboxdrv

If you Virtual Machine runs after that without giving you an error message, then you can activate the vboxdrv module permanently by going to /etc/modules-load.d/ and making a .conf file (such as vbox.conf). In the .conf file the names of the vbox kernel modules you want to add, such as: vboxdrv.

Save and reboot

You can also ad these optional modules: vboxnetadp, vboxnetflt and vboxpci

From Vbox's wiki:

vboxnetadp and vboxnetflt are both needed when you intend to use the "Host-only networking" feature. More precisely, vboxnetadp is needed to create the host interface in the VirtualBox global preferences, and vboxnetflt is needed to launch a virtual machine using that network interface.

vboxpci is needed when your virtual machine needs to pass through a PCI device on your host.

Note: If the VirtualBox kernel modules were loaded in the kernel while you updated the modules, you need to reload them manually to use the new updated version. To do it, run vboxreload as root.

  • 1
    On 2015.04: modprobe: FATAL: Module vboxdrv not found – Nicolas Raoul Nov 17 '15 at 5:09

I found this works for me (quoted from virtualbox.org forum):

sudo apt-get install dkms build-essential linux-headers-generic

If you want further granularity you can install the headers as such:

sudo apt-get install linux-headers-$(uname -r)

After this step reinstall the virtualbox related packages.

Some people in the forum said that only the second version worked for them.

Did you install Virtualbox by downloading it from some web site?

If so, I'd recommend you to install it using the Ubuntu Software Center instead (type Virtualbox and click on install and you're set).

If you have some terminal skills, type this into the console:

sudo apt-get install virtualbox-ose

If you still want to do weird stuff to you computer/OS, then install the dependencies by hand: virtualbox-ose-dkms, libgl1-mesa-glx

  • Thanks, I have no terminal skills but am going to try and learn some :) and I did not install it, but am heading to try the software center. I was getting an error when I tried to update the new Virtualbox so maybe that will help also. I have the Oracle Virtualbox will go into it and see what it has... – Cyndi May 8 '11 at 20:35

I think Chriskin provided the answer, but you also want to make sure you have the proper Linux headers installed, as husni pointed out:

sudo apt-get install linux-headers-`uname -r`

then

sudo apt-get install dkms
sudo /etc/init.d/vboxdrv setup
  • 2
    This doesn't work. The /etc/init.d/vboxdrv file still doesn't exist. It was a nice try though. – weberc2 Jan 10 '13 at 23:47

I had exactly the same problem. My solution was to totally reinstall VirtualBox, with the following commands:

1) Delete (backup) the hidden VirutalBox directory in your home directory

mv ~/.VirtualBox ~/.VirtualBox-backup

2) Reinstall VirtualBox

sudo apt-get purge virtualbox
sudo apt-get install virtualbox

3) Run VirtualBox and set it (Virtual Images) up again.

This worked for me:

wget -O /tmp/virtualbox.patch 'http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=99;filename=vbox-wheezy.patch;att=1;bug=696011'
cd /usr/src/virtualbox-4.1.12/
patch -p4 < /tmp/virtualbox.patch
dkms autoinstall

I had this problem in Kubuntu Vivid. I was struggling for a long time with the error "Your kernel headers for kernel 3.13.0-36-generic cannot be found.", and apt-get was unable to find it in the repositories.

The solution was to add a repository from trusty

deb http://security.ubuntu.com/ubuntu trusty-security main 

to /etc/apt/sources.list, and install with

sudo apt-get install linux-headers-`uname -r 

and then run

sudo /etc/init.d/vboxdrv setup

I am using Ubuntu 14.04, I was having similar problem.My problem is solved by using below command for virtualbox installation:

sudo sh -c "echo 'deb http://download.virtualbox.org/virtualbox/debian '$(lsb_release -cs)' contrib non-free' > /etc/apt/sources.list.d/virtualbox.list" && wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install virtualbox-5.0

Actually it will remove your current version of Virtualbox and will install virtualbox-5.0 from the oracle maintained repository.

The above command is available at https://help.ubuntu.com/community/VirtualBox/Installation

i had this problem with Kubuntu 14.04.3 + virtualbox 4.3.10 from standard ubuntu trusty repository and none of previous solutions worked. the only solution was to add virtualbox.org repository and upgrade to latest virtualbox (4.3.32). you can do that with this command:

sudo sh -c "echo 'deb http://download.virtualbox.org/virtualbox/debian '$(lsb_release -cs)' contrib non-free' > /etc/apt/sources.list.d/virtualbox.list" && wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add - && sudo apt-get update && sudo apt-get install virtualbox-4.3

Not sure where else to drop this but for purposes of completeness: I had the same problem after an upgrade to 15.10. I tried everything mentioned in this post and others to no avail. My problem was that I kept missing hints that the root problem was with the kernel itself. It wasn't properly updated during the upgrade from 15.04 to 15.10. Mine was solved by Ubuntu kernel not updating with 15.10 which I then followed up with both of the "sudo dpkg-reconfigure" mentioned in answers here.

If I remember correctly I installed virtual-box using the .deb downloaded from the virtual box site, on 15.10. I fixed this problem by simply installing this package:

$ sudo apt-get install virtualbox-dkms

None of the answers mention simple solution which works for me.

sudo /usr/lib/virtualbox/vboxdrv.sh setup

I have Ubuntu 15.10 and Oracle VM 5.0.20. I've found the solution in vbox ticket.

I am on Linux Mint Rafaela 17.2, but with kernel update to v4.4 (xenial, 4.4.0-57). Since it is based on Ubuntu 14.04 (Trusty), I added this PPA: https://www.ubuntuupdates.org/ppa/virtualbox.org_contrib?dist=trusty

purged old v5.0 and installed latest VirtualBox:

sudo apt-get update
sudo apt-get install virtualbox-5.1

Voila!

I had the same error on the VirtualBox start after the kernel upgrade. virtualbox-dkms could not be resinstalled because I used the latest (non-default) Ubuntu kernel and virtualbox-dkms has not been patched yet for that kernel:

$ sudo apt-get install --reinstall virtualbox-dkms
...
ERROR (dkms apport): kernel package linux-headers-4.12.14-041214-generic is not supported
Error! Bad return status for module build on kernel: 4.12.14-041214-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.0.40/build/make.log for more information.
Job for virtualbox.service failed because the control process exited with error code. See "systemctl status virtualbox.service" and "journalctl -xe" for details.
invoke-rc.d: initscript virtualbox, action "restart" failed.
● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-10-23 02:31:15 CEST; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 10851 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)
...

So, I ended up with installation of the latest VirtualBox from Oracle, which works fine!

Having upgraded my kernel recently I was unable to boot any images.

I ran

sudo apt-get purge virtualbox

Then I added the 5.1v of virtualbox. I am using Mint, so I ran lsb_release -c to see which version I was using, which was sarah for me, so I added

deb http://download.virtualbox.org/virtualbox/debian sarah contrib

But for Ubuntu users, edit /etc/apt/sources.list file and add one of the following lines according to your distribution to your system:

  • For Ubuntu 17.04 ("Zesty")

    deb http://download.virtualbox.org/virtualbox/debian zesty contrib
    
  • For Ubuntu 16.04 ("Xenial")

    deb http://download.virtualbox.org/virtualbox/debian xenial contrib
    
  • For Ubuntu 14.04 ("Trusty")

    deb http://download.virtualbox.org/virtualbox/debian trusty contrib
    

Now get the cert for these

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

Then update and install

sudo apt-get update
sudo apt-get install virtualbox-5.1

Now you can freely open VB... or at least I could.

protected by Pilot6 Jan 27 '17 at 8:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.