I recently reinstalled my Ubuntu 12.04. The main idea was to not disturb files on /home, and I succeeded by reinstalling Ubuntu only on / partition.

When I got back I found everything working but not ubuntu-tweak. I have found many advices such as reinstalling "compiz" or adding older repositories bot none have worked.

When I start ubuntu-tweak in terminal I receive long bundle of code which I don't really understand. I feel it would say important things but I just can not read it properly.

I simply love ubuntu-tweak software and I would like to have it up and running just as before system swap.

There is my problem :

fahrenheit@fahrenheit-1225C:~$ ubuntu-tweak
(ubuntu-tweak:3173): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Traceback (most recent call last):
 File "/usr/bin/ubuntu-tweak", line 122, in <module>
from ubuntutweak.main import UbuntuTweakWindow
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/main.py", line 40, in <module>
from ubuntutweak.preferences import PreferencesDialog
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/preferences.py", line 32, in <module>
from ubuntutweak.factory import WidgetFactory
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/factory.py", line 24, in <module>
from ubuntutweak.gui.widgets import *
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/gui/widgets.py", line 10, in <module>
from ubuntutweak.settings.compizsettings import CompizSetting
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/settings/compizsettings.py", line 3, in <module>
import ccm
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/settings/ccm/__init__.py", line 1, in <module>
from Conflicts import *
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/settings/ccm/Conflicts.py", line 25, in <module>
from Constants import *
 File "/usr/lib/python2.7/dist-packages/ubuntutweak/settings/ccm/Constants.py", line 77, in <module>
locale.setlocale(locale.LC_ALL, "")
 File "/usr/lib/python2.7/locale.py", line 539, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting
  • 1
    This answer may help you. – souravc Jan 26 '14 at 11:54
  • 1
    Thank you souravc3, you are THE MAN! It worked! :D It did not exactly helped my case but obviously focused me on matter of language issue. I solved it by updating language manager in system settings and toped English language at the top of the list. Suddenly ubuntu-tweak started to run as it should :) Tank you so much and I would like to thank someone who edited my question so neatly as I would like to post it. I would mark the problem solved but I don't really know how ;P – user239985 Jan 26 '14 at 15:15
  • nice to see that your problem is solved. you can write the answer by yourself stating how you solved the issue and accept it. See self-answer – souravc Jan 26 '14 at 16:53


sudo apt-get purge locales


sudo aptitude install locales

and the famous:

sudo dpkg-reconfigure locales

This rids the system of locales, then re-installs locales and downgrades libc6 from 2.19 to 2.13 which is the issue. Then configures locales again.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.