As a new Ubuntu user I've tried several distro's including Mint. Everything works except for my graphics card. The laptop has an GT 740M gpu which has Optimus. Now I've tried a lot of tutorials to the 'Cannot access secondary GPU' issue, including installing bumblebee, primus and a lot of other things including the linux headers. Ive also edited the .conf file changing the Driver= to Driver=nvidia-current method.I'm running 13.10

Nothing works, sometimes I get a black screen, sometimes nothing happens. But I always end up with the same error:

[ERROR]Cannot access secondary GPU - error: Could not load GPU driver [ERROR]Aborting because fallback start is disabled.

when Using the lspci | grep 3D command I get: 01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

Opening my /etc/bumblebee/xorg.conf.nvidia I get:

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"

I came across this issue when I tried installing Dead Space 2 using PlayOnLinux. It kept giving me the error that my laptop didn't meet the required specifications.

Remember, I've tried a lot of tutorials and google and nothing worked, so if anyone could give me a detailed explanation and fix in such a way I can understand; This is no longer an annoying issue, I want seriously want to know how to properly troubleshoot and fix these kind of problems ;)

Thanks a lot in advance!

  • Looks like the nvidia kernel module is failing to load, or the bumblebee daemon isn't started. Report the output of dmesg after starting the daemon for errors. Also, if you're using Kernel 3.13, askubuntu.com/questions/409465/… is applicable to your problem. – Kent Fredric Jan 29 '14 at 9:20

Here goes my best attempt at explaining our troubles. The nvidia Optimus is actually integrated graphics (or hybrid graphics https://help.ubuntu.com/community/HybridGraphics). So it's new technology where the GPU and CPU are physically wired together.

Also because nvidia is nvidia they suck at open source (Linus actually flicked them off at a conference) and their drivers for Linux to allow the system to run aren't working properly. They stated they had no plans to support at this time(https://askubuntu.com/tags/nvidia-optimus/info). Instead it's fallen to users, hackers, and whoever else (not sure who is working on which thing) to develop the drivers for the integrated graphics. However without knowing the full details of how it's built the best anyone else can do is try to implement things based on reverse engineering the system itself. This has led to the many issues. So overall it's currently a sad state of affairs.

There does seem to be hope coming in update 14.04 (http://m.webupd8.org/2013/12/more-work-to-support-nvidia-optimus.html?m=1). Also nvidia "promised" to release more details on their systems (maybe because of the upcoming steam box?) to allow for more and better driver development but we're still waiting on that.

Good luck,


Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.