I created a desktop shortcut using this command:

 `gnome-desktop-item-edit –create-new ~/Desktop`

Then I thought it would be a great idea to see if I can drag the icon onto the launcher. I tried twice in order to manage. Unfortunately now I have the icon I wanted originally, plus an empty space onto my launcher which, when I rollover, says "Drop to add application". I removed the original icon, but the empty space remains. BTW, nothing happens when I click on the empty space.

Ah, this is the first time I am using Ubuntu, I fell in love with it, but now I have a feeling my new operating system is too fragile to play around with, and even worse, I get a feeling of helplessness :) Complex feelings associated with an OS:)

Please help, I would hate to have to reinstall the whole think again!

  • Can you add a screen shot? it may help – user.dz Jan 25 '14 at 12:10
  • 1
    Ah, I fixed it! I did this: unity-reset and it, well... reset the launcher (along with other bits I assume, but I am not concerned with those:)) – andgeo Jan 25 '14 at 12:50

Try running

unity --replace

in terminal. If that doesn't work, you can reset it using

unity --reset
  • Just an FYI - unity --reset is now deprecated and should not be used. Taken from unity --help: Reset is not supported anymore. Deprecated option. – RPiAwesomeness Dec 26 '14 at 1:35

Look at this question :

"invisible" icons in the launcher bar

Try to find your answer

  • Unfortunately my answer was not in other. I had checked that one before posting my question. But I fixed my problem by doing unity-reset in the terminal! – andgeo Jan 25 '14 at 12:51

I solved running

unity --reset-icons

but it will close most of your running apps, so close them prior to execute.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.