My laptop is Acer Aspire 4745G with dual graphics Intel/AMD. Discrete card is Mobility Radeon HD 5430/5450/5470. I'm using Ubuntu 13.10 now.

One day I mentioned that my discrete AMD graphics card is not working, after some googling I found a way how to check it and command fglrxinfo gave me X Error of Bad Request. And so started my big quest for trying to make it work.

I tried so many ways from Google but no one of them really helped - I still can't use discrete card. I wouldn't even want to be able to switch them - I just want a discrete one work.

The last one I tried is installing driver from official site. Ok, so I installed it with sudo sh ./amd*.run, it processed and gave me DKMS error in the end or smth like that. After that I rebooted and got a message that system couldn't detect drivers and so on.

So my question is:

  • how do I install drivers for my graphics card now, in 2014?
  • Ok, the last one was this: I installed a fresh Ubuntu 12.04 from official website and installed the latest driver from AMD website. Installation seemed to finish up ok, but after reloading I got a message about low-graphics mode. – Sergey Chupov Jan 28 '14 at 12:38
  • I followed this guide and after reboot I got "The system in running in low-graphics mode" message. – Sergey Chupov Jan 30 '14 at 14:10

You can try with this tutorial: https://xpressrazor.wordpress.com/2013/10/08/enable-and-use-open-source-radeon-drivers-in-a-muxless-hybrid-graphics-intelamd-setup/

I have an AMD/Intel Hybrid graphic system, anda thar was my choice. I don't want to use the privative driver (so many bugs... and, it's PRIVATIVE, I mean).

Now, my system works nice, with a pretty good performance in games, and without any fan problem.

  • 3
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kaz Wolfe Sep 30 '14 at 6:31
  • Sorry for not responding so long. I found a lot of solutions on the Internet, but none of them helped. Finally I happened to change the laptop, so I forgot about this question. Unfortunately, I didn't check the suggested tutorial, so I would appreciate if someone tries it and tells us whether it helped. – Sergey Chupov Oct 15 '15 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.