3

I was trying out compizconfig settings manager and after a while I noticed that my screen is shifted about 5 pixels to the top left direction. So at the right and bottom i have a 5 pixel wide black area. I guess some compizconfig feature messed it up.

If I log in as guest, everything is fine, so the problem is localized to my account.

I tried deleting config files, but it didnt help:

rm ~/.gconf ~/.gconfd ~/.metacity ~/.compiz-1 ~/.config/compiz-1 ~/.config/dconf -rf

Additional information:

xrandr returns:

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 4096 x 4096
DVI-I-1 disconnected (normal left inverted right x axis y axis) VGA-1
**connected 1280x1024+0+0** (normal left inverted right x axis y axis) 376mm x 301mm
1280x1024      60.0 +   75.0*
1280x960       60.0
1152x864       75.0
1024x768       75.1     70.1     60.0     
832x624        74.6
800x600        72.2     75.0     60.3     56.2
640x480        72.8     75.0     66.7     60.0
720x400        70.1
TV-1 disconnected (normal left inverted right x axis y axis)

I have no idea what causes this, but it is very annoying because I can't see on launcher, which programs are running. I have hope, because for the guest it works, maybe I just need to delete more config files? or purge compiz and reinstall it??

1

I had this same issue. Drove me nuts. Turns out it was the grub2 bootloader, which is loaded even if Ubuntu is your only OS (i.e. not multi-booting). Turn on computer -> grub loads and confuses screen resolution -> Ubuntu loads and tries its best but gets it wrong by 10px to the left and 10px up. It even confused Windows when I used grub to load it. Grrrr grub.

I fixed my problem by editing the grub bootloader and manually setting the resolution. I'm no wizard, so I used Grub Customizer. In my case, I have a 1440x900 monitor and setting it to 1280x1024 worked great. Once Ubuntu loads, I have ful 1440x900. I even got to set a custom background for Grub, so that's cool.

I couldn't promise this will fix your problem. I never tested a guest account and couldn't say why this would be different.

...

If you're tempted to test Grub to see if it's part of your problem, you could enable its menu display on a solo-Ubuntu installation by editing its config file.

  1. gksu gedit /etc/default/grub
  2. change GRUB_HIDDEN_TIMEOUT="0" to ' #GRUB_HIDDEN_TIMEOUT="0"
  3. sudo update-grub
  • I am not sure if grub could cause my problem, as far as I – Jani Kovacs May 6 '14 at 16:52
  • Ya, it's odd that you're affected on one account and not guest account. New info added to answer. – John May 6 '14 at 19:57
  • Have you tried creating a new user account to see if it's affected? If a new account isn't affected, you could migrate your files over and start using it. You could migrate program-specific settings, too, by copying their program-specific folders in your home dir. (e.g. /home/yourname/.mozilla) You'd then have to delete your old user account, rename your new user account to something you like. Downside is that your new home folder will have a new location (i.e. /home/newname) Good luck bud. – John May 6 '14 at 19:57
  • yes, that's what I did. I am not going to experiment with solutions for which I cannot see how it would be account specific however. My guess is that some pointers got changed by compizconfig as part of a poor design choice and it cannot be reset by usual measures. – Jani Kovacs May 8 '14 at 16:56
  • I don't see anywhere on your text where you mention having tried actually resetting Unity, so I'll suggest that and wish you good luck. How To Reset Unity And Compiz In Ubuntu Cheers – John May 10 '14 at 5:18
0

I succeeded at doing it again, but this time I caught it!

A small innocent-looking file gets created: /home/myname/.config/monitors.xml it does not contain anything like shifting the screen by some small amount, yet if you delete it, the problem is gone.

I suspect that this file is no use for anyone. since it is gone, everything works fine. I suspect that when I play around with settings and I sort of wreck the current session, some exception-handling kicks in, and creates this file, but the cure is worse than the disease, it appears.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.