0

So, I had a weird scenario just happen and I was just hoping someone might know what happened for my own edification. Basically, a while back I installed syslog-ng v 3.3.6 using

sudo apt-get install syslog-ng

I wanted to update my version of syslog-ng that I was running but after running install and checking:

sudo syslog-ng -V 

it said it was still running 3.3.6. Even when I ran an

sudo apt-get remove syslog-ng 

the output would say it was removing but syslog was still running on the machine and still said it was running 3.3.6.

I updated my sources.list to point to the unofficial repos as per this link. updated my apt-get and then ran

sudo apt-get remove libsyslog-ng-3.3.6

It removed 3.3.6 and installed 3.4.7, which is what I wanted to happen but I'm just really not sure why all of the above happened. Specifically, Why didn't it actually remove syslog-ng? and why did it remove 3.3.6 and auto-install 3.4.7?

0

1 Answer 1

0

Just reboot: If syslog-ng is already running as a service than it is stored in RAM until it's terminated, thus updates and uninstall will have not effect.

2
  • Hm. I tried rebooting after the update and nothing happened. Never tried after the remove, though.
    – MilkyC
    Jan 25, 2014 at 0:05
  • Strange that it didn't work after the update. Perhaps it wasn't really updated, but just installed along side the old verstion. pkill syslog-ng should work in place of a reboot
    – virtualxtc
    Jan 25, 2014 at 0:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .