Can anyone walk me through the process of installing Bitcoin on Ubuntu? I'm new to linux, and this is really all I want to do with this computer.



Launchpad has a Personal Package Archives (PPA) for bitcoin.

You can add this PPA to your system's software sources: ppa:bitcoin/bitcoin After that you can search ubuntu software center for bitcoin or from terminal sudo apt-get install bitcoin

By the way: bitcoin is only available for maverick and lucid so after adding the PPA change the distribution to maverick.

And a screenshot to finish it off:



To change from 'natty' to 'maverick' for a PPA you can do this from the Ubuntu software center: usc

Click the bitcoin PPA and choose edit. Next it changing 'Natty' to 'Maverick': usc2

Reload the sources (it will prompt for it) and you should be able to install maverick's version of 'bitcoin'.

| improve this answer | |
  • 1
    Consider what you're up against: Dedicated custom-designed Bitcoin miners arstechnica.com/gadgets/2013/06/… which cough up $20/day in exchange for a kilowatt-hour. Bitcoins are an increasingly poor investment zdnet.com/… for legitimate miners. Compare your hardware with what's out there litecoin.info/… before you decide. – K7AAY Jan 23 '14 at 18:42

Bitcoin has now an officially maintained PPA with a release candidate version of the peer-to-peer daemon and the client.

Bitcoin has a launchpad project i.e. same project status as Unity/Docky/Openshot etc. The maintainer - Matt Corallo - is a major contributor to the official bitcoin.org website.

This will upgrade all versions from 10.04 and later.

The following instructions will upgrade your system to the latest version of the client

sudo add-apt-repository ppa:bitcoin/bitcoin 
sudo apt-get update
sudo apt-get install bitcoin-qt

Confirmation that this OK to use is via the bitcoin forums.

| improve this answer | |
  • 1
    @pedrorolo Bitcoin project page says the that the bitcoin team is responsible for the repo packages as well as the PPA. As such, I'll be awarding this answer my bounty. – Oxwivi Nov 4 '11 at 12:43
  • I may be wrong, but bitcoin needs Berkely DB version 4.8 and this is not supported on all Ubuntu version (oneric for example). – puk Dec 4 '13 at 22:24
  • 1
    and who is behing the 'bitcoin team'? – knocte Feb 5 '16 at 10:16


bitcoin with Unity doesnt work due to an issue with Compiz - this is the bug report

This issue has been discussed with a few suggestions on the bitcoin forums

In summary - if you dont want to install

  1. a new versions of bitcoin either via ppa's or from the latest source on the bitcoin website, or
  2. update the wxwidget libraries,

you should logout of Unity and choose the session "Ubuntu classic (no effects)" - i.e. running ubuntu without any compiz effects.

| improve this answer | |
  • So how do we update the wxwidget libraries? – Oxwivi Jun 27 '11 at 8:13
  • @Oxwivi - worth a new question if you want perhaps detailed steps - in summary goto wxwidgets.org and download and compile the latest source-code from the wxWidgets-trunk – fossfreedom Jun 27 '11 at 8:29
  • Quite helpfully, it seems they provide a repo with these instructions. – Oxwivi Jun 27 '11 at 8:37

I set up this script which seems to have worked for me on both Ubuntu 11.10 oneiric and on Ubuntu 13.10 saucy. However, I am sure it is full of problems and installing code you might not potentially need. If anyone is a better bash programmer go in there and insert some if [ ...] statements to not install all packages.


# Word of caution, I am not an experienced shell programmer. All I can #
# guarantee is that this script has worked for me, and that it has     #
# done so on multiple Ubuntu machines (one 11.10 and one 13.10), so    #
# hopefully it will work for you too                                   #

# Install some packages as instructed on various web sites
sudo apt-get -y install qt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev libssl-dev
sudo apt-get -y install libtool autotools-dev autoconf
sudo apt-get -y install libdb4.8-dev # Generally this step fails
sudo apt-get -y install libdb4.8++-dev # Generally this step fails
sudo apt-get -y install libboost1.37-dev # Sometimes this step fail
sudo apt-get -y install libboost-all-dev # Sometimes this step fail
sudo apt-get -y install libminiupnpc-dev
sudo apt-get -y install libdb++-dev
sudo apt-get -y install libprotobuf-dev
sudo apt-get -y install libqrencode-dev

# Build berkley db4.8
# Technically, this should only be installed if the above              #
# libdb4.8XX-dev packages failed to install but nothing beats a little #
# overkill =)                                                          #
cd ~/Downloads
if [ ! -e db-4.8.30 ]
   wget http://download.oracle.com/berkeley-db/db-4.8.30.tar.gz
   tar zxvf db-4.8.30.tar.gz
   rm -f db-4.8.30.tar.gz

cd db-4.8.30/build_unix
../dist/configure --prefix=/usr/local --enable-cxx # If this doesn't work, try removing or changing prefix
sudo make install
cd ~/Downloads
rm -fr db-4.8.30/ # If it still doesn't work, try commenting out this line

locate libdb4.8-dev # Comment this out as it may cause problems

if [ $? -ne "0" ]
   Failed to install db-4.8.30
   exit -1

# Build bitcoin
cd ~/Downloads
if [ ! -e bitcoin ]
   git clone https://github.com/bitcoin/bitcoin ~/Downloads/bitcoin

cd bitcoin

./configure # Non Ubuntu 13.xx versions
# ./configure --with-boost-libdir=/usr/lib/x86_64-linux-gnu # Ubuntu 13.xx version

cd ~/Downloads
rm -fr bitcoin
| improve this answer | |

You can try using this ppa: bitcoin David Armstrong ppa launchpad

In your terminal window (press Alt+F2 and type gnome-terminal) and copy+paste the following lines:

sudo add-apt-repository ppa:stretch/bitcoin
sudo apt-get update && sudo apt-get install bitcoin
| improve this answer | |

In addition to fossfreedom's answer, you may need to install add-apt-repository. For example on Ubuntu Server (16.04 LTS)

You'll see this error:

sudo: add-apt-repository: command not found

In that case, for 16.04, you need the following commands:

sudo apt install software-properties-common
sudo add-apt-repository ppa:bitcoin/bitcoin 
sudo apt update
sudo apt install bitcoin-qt

But for a server, you'll quite likely don't want bitcoin-qt but bitcoind. Change the last line to:

sudo apt install bitcoind
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.