I have been using Xubuntu and Ubuntu on our older home PC for almost 2 years without much trouble until today when the mouse seemed to not work properly. I can move the pointer around and click but after a while the left and right click does not work. I can hover over a button and clicking shows the visual effect of lowering the button but it won't respond with the action required. It seems to happen sooner when opening a firefox window, but is not restricted to firefox. I have looked on this forum and others for advice and I have tried the following:

compiz --replace
metacity --replace

I have even reinstalled the Xserver. I checked the ximput to see if the buttons were not assigned but everything seems OK. I am on the 3.2.0-54 kernel and running Xubuntu/Ubuntu 12.01. And I have tried different mice on different usb ports and they all do the same thing. Help will be much appreciated.

  • It seems to be only when I start firefox from the cairo-dock. – Jacques MALAPRADE Jan 23 '14 at 21:41
  • Please add the firefox & cairo-dock bit in the original question by editing it. I'm wondering what happens if you open firefox from the xfce4-panel; do you still get the non-functional mouse? Maybe it is the cairo-dock thingy that bugs out and botches the mouse. – landroni Jan 24 '14 at 6:30
  • I now noticed it does the same thing in ubuntu and xubuntu so not just a cairo-dock problem. I came across a site suggesting I should add the following to the firefox shortcut: GDK_NATIVE_WINDOWS=TRUE firefox. I have tried adding it to the firefox.desktop file as well as the /usr/bin/firefox file but they all seem to not work. I .desktop I added it to the line starting with Exec=.... I am currently testing something and it seems to be promising that is to add " GDK_NATIVE_WINDOWS=TRUE firefox " as a env variable before starting firefox. It seems to work but needs more test. Will get back... – Jacques MALAPRADE Jan 25 '14 at 12:22
  • Ok tried by rebooting and using the firefox from menu and running from terminal works but not trough cairo-dock. Rebooting again anf trying the env variable method again to see if firefox works. – Jacques MALAPRADE Jan 25 '14 at 12:32
  • From what I hear, this issue is only related to Firefox (whichever the DE) and not in other apps, correct? – landroni Jan 25 '14 at 12:52

A distribution upgrade was what was needed:

sudo apt-get update
sudo apt-get dist-upgrade

I don't know how but my previous kernel must have been corrupted.

  • 1
    Great you solved it. After a small time-period, feel free to accept your own answer. – landroni Jan 28 '14 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.