3

I have a weird problem. I can connect my android phone to my laptop, it keeps connecting/disconnecting (about twice per second). I tried on another laptop with Ubuntu installed, and it worked fine.

Big problem is that, aside of no file transfer, I can't charge my phone. I keep getting the message "unable to open MTP device '[usb:003,]'", where num keeps increasing (I assume it is communication attempts).

What may be causing this problem? I have no idea where to start. It's the only USB device that does that (my ipod charges fine, and I can even access the music no problem).

Is there a way I can "deaden" one of the usb ports, such that only power is provided, but no data transfer attempts?

P.S.: My phone is a Samsung Galaxy S2.

P.P.S: It does that on all USB ports.

  • Do you have go-mtpfs installed? If yes, have you tried mounting trough this? – Michael Jan 23 '14 at 18:26
1

Use the PTP connection instead of MTP - for some reason I always have this problem in Ubuntu, but never in Fedora...

You should get a Notification on connection, touch it and select PTP:

enter image description here

I think on older versions of Android there was 'Mass Storage Mode'

Works on Android 4.1

Also, make sure libmtp is installed.


Also note, there is a revolutionary concept - turning the phone off...

  • 1
    I had tried both PTP & MTP, same behaviour. I had libmtp installed already (under libmtp-common) – morphheus Jan 23 '14 at 21:32
  • This could be of help... – Wilf Jan 24 '14 at 10:50
  • Thanks; I was never able to transfer files from ubuntu to Android. Still, my problem persists: Ubuntu tries to connect to the device, but gives a DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus) . – morphheus Jan 25 '14 at 3:16
  • As I pointed in the OP, I cannot even charge my phone (but I can do so on other ubuntu computers). This seem to be an install-specific problem, not a ubuntu-specific problem. – morphheus Jan 25 '14 at 3:17
1

For me it was the usb cable which was bad, with a good quality USB cable it corrected the problem

And as a workaround, using Samba on your phone as mentioned in [this tread][1] worked for me as the best solution (take a look @ the sdcard share adding in the settings of the application)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.