2

On Ubuntu 13.04, many of my dvips calls deliver error messages like,

dvips: Font Helvetica used in file <...> is not in the mapping file.

All these calls work perfectly fine on Ubuntu 12.10 which I'm using in parallel on my laptop. gv can also display the 'missing' fonts if called directly, so I guess they are installed correctly and it must be an issue with dvips in Ubuntu 13.04

I've installed

texlive-fonts-recommended
texlive-fonts-extra

Any ideas?

2

This bugged me for ages. This is my solution that works:

  1. Locate the file dvips35.map

    locate dvips35.map
    

    In my case it is in

    /usr/share/texlive/texmf-dist/fonts/map/dvips/tetex/dvips35.map
    
  2. Create a new file called .dvipsrc in your home directory

    gedit $HOME/.dvipsrc
    
  3. And copy and paste the following:

    p +/usr/share/texlive/texmf-dist/fonts/map/dvips/tetex/dvips35.map
    
  4. Run updmap to update the configuration. Helvetica and Times-Roman should now be available.

If you have root access you can add the line in step 3 at the end of the file

sudo gedit /usr/share/texlive/texmf-dist/dvips/config/config.ps

and run sudo updmap-sys. The above location is 14.04. You can locate your own config.ps file using:

locate config.ps
1

Just a shot --- have you tried to install gsfonts-other?

apt-get install gsfonts-other

On the other hand, I often had that warning with no ill effects on my output -- check if this is the case. It happened when the dvips swallowed some ".eps" figure.

(Otherwise, try to add a small example file --- so that people can check).

0

Thanks, but that's not it, gsfonts-other is installed, and gv can display the fonts. It is also not just a warning, the symbols are really missing. E.g. when I use the Symbol font, the characters are in the .eps when I directly look at it with .eps, but not in the final .eps when I feed the very same file into a .tex document and go through dvips. When I look at the intermediate .dvi with xdvi, the syms are there, but as soon as I dvips them, I get aforementioned error message and the syms are gone in the .ps, so I guess it must be an issue with dvips.

Thoughts much appreciated :)

0

The "official" dvips home page http://www.radicaleye.com/dvips.html says that for error messages or core dumps, use option -j0 to work around some issues with current versions of dvips until it gets fixed someday. I have no idea what this option does, but it worked for me to get latex to work right with imported eps files that have timesroman and helvetica fonts; these same eps files used to work fine for many years on older versions of dvips, but now don't work with current versions. Using the -j0 option, I still get the error messages, but the output of dvips now comes out correct with no missing characters or symbols. So give it a shot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.