I have a problem with my Ubuntu OS that I've been trying to solve for the past 2 weeks with no results. I've probably put 14 hours into solving this problem.

When I use the suspend option on my computer, it breaks the operating system. The OS suspends as it normally should (dark screen, blinking power light, etc.) but it does not wake up properly. When I try to wake it up, the backlight turns on and the fan starts and everything but the screen is black. I've tried different key combinations (CTRL+ALT+F2 for example), putting in USB drives, pressing the power button, but none of it will turn the screen bright. The screen stays frozen black and the computer is running as if it were awake (fan whizzing and stuff).

I am forced to hard restart the system every time I choose the suspend option.

Hibernate is similar. When I type

sudo pm-hibernate

The computer will go dark, but will not power down. If I move the mouse it will turn back on to a black screen with a blinking cursor. CTRL+ALT+F2 will go to a terminal window, but upon typing anything in the terminal window will freeze.

I've tried a number of ideas including all of them here: Ubuntu freezes/crash after wake when upgraded to 13.10 and here: http://wafflesatnoon.com/2012/11/17/ubuntu-suspend-wont-wake-up-my-quest/


Ubuntu 13.10 on a HP Pavilion g6-2235us Trinity [Radeon HD 7520G] video driver

  • Could it be that your screen brightness is set back to 0? Try to increase your brightness with the Fn keys. – OrangeTux Jan 23 '14 at 15:54
  • I have tried increasing the screen brightness also, to no avail :( If that were the problem though it would be strange since my computer cannot go that dark – Paul Terwilliger Jan 23 '14 at 16:09
  • I have a pavilion g6 and am having the same issue. I am running ubuntu studio. Did you resolve this. – Mike Dennis Mar 3 '14 at 13:18

Try installing the fglrx driver : sudo apt-get install fglrx and then reboot.


The same thing happens to me. I have researched that it was a driver problem. I can't do anything to get out of suspend or hibernate without force-restarting cinnamon (In my case, I have Linux Mint 17 cinnamon on an HP Pavilion g6 with AMD Trinity driver) by doing Ctrl+Alt+Backspace several times. THEN when that works, GRUB appears after a long wait, then everything works fine when you load Linux again. I have also heard Ctrl+Alt+F1 then Ctrl+Alt+F7 while suspended should work, though I have never tried it. Play with your drivers and test everything out if in doubt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.