I'm trying to install the armel version of Ubuntu with qemu-deboot-strap on my desktop X64 system,but I've found this error :

$ mkdir precise

$ sudo qemu-debootstrap --arch=armel precise ./precise/

I: Running command:

 $ debootstrap --arch armel --foreign precise ./precise/
 /usr/sbin/debootstrap: 1280: /usr/sbin/debootstrap: cannot create  /media/ziomario/Nexus-10/Images/313/precise/test-dev-null: Permission denied

E: Cannot install into target '/media/ziomario/Nexus-10/Images/313/precise' mounted with noexec or nodev

do you know how to fix it ? my system is like this :

Linux ziomario-Macmini 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and this is the content of the /etc/fstab file :

<file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0

/ was on /dev/sda5 during installation
UUID=c703f96e-42fd-4734-b622-15ba1dd5fc21 /               ext4    errors=remount-ro 0       1

swap was on /dev/sda6 during installation
UUID=1c2b872f-3be3-4c6c-b021-6cec3e8b77e2 none            swap    sw              0       0



1 Answer 1


Remounting with exec and dev is the solution. If your filesystem is encrypted, you also need to pass -i to mount.

 sudo mount -i -o remount,exec,dev /home/user

Where in my case /home/user/ is my encrypted home directory. After that debootstrap had no issues any more.

I found this answer here on Super User and it worked for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.