I've been looking around the internet for tutorials on how to add the Korean keyboard. As of now, the only thing I've done is I added the Korean language in my Region & Language system settings. Please help!

I hope that this helps. I struggled for some time with this exact same problem. I used to have no problem prior to Ubuntu 13.10. I just upgraded to 14.04 and decided to figure it out again... got it this time and it is REALLY SIMPLE and WORKs... it just isn't too straight forward and there are misleading problems with the adding keyboard step... anyway... try he following and let me know if this works for you!!!

Summary: How to set Ubuntu 14.04 to utilize Hangul.

Background: Since Ubuntu 13.10, the ibus interface became difficult to setup for Hangul. There were issues (most resolved by 14.04) with switching keys. Primary issue appears to be if you want to set the Right Alt key to serve as the "Hangul" key to switch between input modes. This is compounded by the fact that Linux utilizes many keyboard shortcuts and conflicts with modifiers persist. In the past, the dialogs required for setting up IBus for Korean were much different. Ubuntu is on the correct track with the Keyboard Language setup; however, it is confusing for those of us that utilized previous procedures due to lack of information.

Issues:

  • Ability to utilize the Right Alt key for selecting Hangul.
  • Zenity (the program that provides GUI interfaces for many scripts, doesn't display the im-config properly. For that reason, recommend running from command promt (terminal) with -c option.
  • It is misleading for users of a clean install to be able to select "korean" keyboard from Text Entry prior to installing the correct package (or rather, that the selection doesn't trigger installation of the ibus-hangul package.

Process:

  1. Install ibus-hangul Code:

    sudo apt-get install ibus-hangul

  2. Run im-config to configure the IM client. If your system is not a "COMPLETELY clean" install where everything is new (ie - did not remount an older "home" partition), recommend that you run im-config twice. First run, delete the config in your home directory. Second run, select ibus as the input method. From a terminal (CTRL+ALT+T) Code:

    im-config -c
    
  3. Setup "Text Entry Settings". From Dash, type "Text" and select "Text Entry" option. Alternatively, select system syettings (Power/Config icon top right of screen), then select "Text Entry" option. Once in the screen, execute the following steps:

    • In bottom left, click the + to add a keybaord.
    • In new dialog box - filter list by typing "Korean"
    • You will SEE three options: Korean Korean (101/104) Korean (Hangul)

SELECT "Korean (Hangul)" and click ADD.

*If you do not see Korean (Hangul) in the list, restart the computer.

  1. Configure Korean Keybaord -- Select "Korean (Hangul) in the "Input Sources to Use:" part of Text Entry. Now, in bottom right of the "input sources to use" you will see a "configure" button right next tot he small "Keyboard" icon. Select that to configure the Hangul input options.

  2. OPTIONAL: You may wish to configure the keyboard switching options. Default is "Super + Space". I don't like that, so I default mine to an alternate key (currently the "menu" key which I rarely use). Right Alt doesn't work (my preferred since that is the location for the "hangul" key normally.)

Select System Settings -> Text Entry and add it there.

protected by Community Nov 11 '14 at 4:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.