I have a VM box with LAMP installed

I use the shell (with ubuntu 12) to connect to the VM box and real server (dell poweredge), every time I press page up or page down, the screen does not get refreshed on both VMs and Physical servers.

Both VM and real server have this config:

  • 2 gigs ram
  • 1,8G processor
  • 250g hdd
  • 2 x gigabit LAN port #1 used, port #2 not used
  • Both are plugged to a 1u switch
  • all servers has Ubuntu server 12.04

Client's computer:

3.2 G I5, 16g ram, SSD, Nvidia gtx550ti with Ubuntu 12.04

I tried this solution: https://stackoverflow.com/questions/7078538/refresh-vim-buffer

works but it's a pain to do every time i press up arrow, page up etc...

I have this in my .vimrc:

set nowrap
set showmatch
set tabstop=4
set shiftwidth=4
"set expandtab
set ruler
set foldcolumn=2
set nowrap
nmap <F8> :set wrap! wrap?<CR>
"nmap <F6> :e /tmp/a<CR>
"nmap <F7> :w! /tmp/a\| wq!<CR>

" change // style comment to phpDoc comment
map <C-P> :!php -l %<CR>

set hlsearch
"set incsearch
set background=dark
"set textwidth=1000
"set number
"set backspace=indent,eol,start
set noshowmatch

syntax on
let g:loaded_matchparen=1 
:set nocp

is there a solution to fix the problem?

up vote 2 down vote accepted

You can try to put these in your .vimrc:

  autocmd GuiEnter * set background&

  set ttimeoutlen=100
  set ttyfast
  set lazyredraw

  :au CursorMoved
  autocmd BufReadPost quickfix map <buffer> <leader>qq :cclose<cr>|map <buffer> <c-p> <up>|map <buffer> <c-n> <down>
  set synmaxcol=120
  set nocursorline
  set re=1

Another solution can be:


I had the same issue and these worked for me on my 15k drive. On my SSD drive these never worked, do you have a SSD drive by any chance?

My error was similar, I had a SSD drive to another SSD drive using a bad network switch and poor network cables. I changed everything and since then I don't have any issues.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.