This question already has an answer here:

Alright, I installed Ubuntu 13.10 the other day and I'm loving it except for one thing: my Wacom Intuos Pen and Touch (cth-480) doesn't work.

I've tried to install the drivers from sourceforge (http://sourceforge.net/apps/mediawiki/linuxwacom/index.php?title=Input-wacom) to no avail.

I've been searching the internet for several days now but I haven't found anything pertaining to my version and my tablet.

Keep in mind I know next to nothing about Ubuntu.

Thanks!

marked as duplicate by Rmano, Florian Diesch, souravc, user117103, Avinash Raj Mar 14 '14 at 23:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

I have an Intuos Pen&Touch Medium (CTH-680) and was able to get it working in 13.10 using the information here:

http://forums.linuxmint.com/viewtopic.php?f=42&t=110408

The need to manually patch and compile the kernel support may sound frightening at first, but by carefully following the instructions, I succeeded at this as a relative layman.

If I understand correctly and you're using one of the new models like me, you'll want to pay close attention to the P&T-specific instructions in post 3 of the thread. These are where the patching comes in.

Getting the tablet working in general is easy; getting the buttons working including hotplugging is fiddly and I never succeeded at it. The script for the Wacom Manga submitted by a user at the end of the thread got the buttons on my P&T working once I added made that script executable and added it to my Startup Applications. The difference between "working" and "working including hotplugging" is that if I unplug and tablet and plug it back in, the buttons don't work until I run the script again.

It seems that 14.04 will support the new Intuoses out of the box, by the way.

  • Thanks for the reply! But I got really confused after part III. Things were going smoothly, but at part IV I didn't know what to do because the Terminal commands weren't working and I have no idea what "xsetwacom" is. I tried skipping ahead but that made me even more confused – MustangMike Jan 24 '14 at 3:12
  • Hi there! Basically, parts III and IV are about the two ways of customizing the tablet settings, including getting the buttons to do something. In my opinion, only getting the buttons to do something is really important. Part III describes how to do it in a way that will let you unplug/plug in your tablet during a session with no hassle. However, I wasn't able to understand it. Part IV describes how to do this in a simpler way using a script, but if you want to plug in your tablet during a session, you'll need to run the script again. Post 4, not by the thread author, has an example script. – Erik Piper Jan 25 '14 at 12:55
  • xsetwacom is a command that can show or change tablet settings. Bash scripts, like the example script in post 4, are nothing more than a series of commands strung together (often with programmery stuff on top, but not here). So, the example script just runs a series of xsetwacom commands. In short then, you need to: * download the example script to somewhere (I made a hidden folder called "/home/erikp/.wacom" and put it there for example) * edit it to taste in gedit (e.g. I chose ctrl z, ctrl y, -, shift =) * right-click it in the browser, go to Properties, make it executable (continued) – Erik Piper Jan 25 '14 at 13:04
  • * run Startup Applications and add your script to the startup apps. If you put it in a hidden folder like I did then be sure to show hidden folders :-) Oh crap - one other thing - you'll need to replace the "device" string with the right one for your device. To find the device name, go to the command line and use: xsetwacom list The tablet's device name is the part before the words "eraser" etc. – Erik Piper Jan 25 '14 at 13:11
  • By the way, if you use GIMP, there's some twiddling needed to get pressure sensitivity and the eraser working. But I've spammed enough for now... if you do plan to use GIMP let me know. – Erik Piper Jan 25 '14 at 13:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.