3

I tried to install sagemath via command line but encountered a problem. Am I doing something wrong? I have Ubuntu 13.10.

jaakko@jaakko-VPCEB1S1E:~$ sudo apt-add-repository -y ppa:aims/sagemath
gpg: keyring `/tmp/tmp7y1mxl/secring.gpg' created
gpg: keyring `/tmp/tmp7y1mxl/pubring.gpg' created
gpg: requesting key BE796FF2 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp7y1mxl/trustdb.gpg: trustdb created
gpg: key BE796FF2: public key "Launchpad PPA for AIMS" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
jaakko@jaakko-VPCEB1S1E:~$ sudo apt-get update
Ign http://fi.archive.ubuntu.com saucy InRelease
Ign http://fi.archive.ubuntu.com saucy-updates InRelease                       
Ign http://fi.archive.ubuntu.com saucy-backports InRelease                     
Ign http://ppa.launchpad.net saucy InRelease                                   
Hit http://fi.archive.ubuntu.com saucy Release.gpg                             
Hit http://fi.archive.ubuntu.com saucy-updates Release.gpg                     
Ign http://extras.ubuntu.com saucy InRelease                                   
Hit http://ppa.launchpad.net saucy Release.gpg                                 
Hit http://fi.archive.ubuntu.com saucy-backports Release.gpg                   
Hit http://fi.archive.ubuntu.com saucy Release                                 
Hit http://ppa.launchpad.net saucy Release                                     
Hit http://extras.ubuntu.com saucy Release.gpg                                 
Hit http://fi.archive.ubuntu.com saucy-updates Release                         
Hit http://fi.archive.ubuntu.com saucy-backports Release                       
Hit http://extras.ubuntu.com saucy Release                                     
Ign http://security.ubuntu.com saucy-security InRelease                        
Hit http://ppa.launchpad.net saucy/main i386 Packages                
Hit http://fi.archive.ubuntu.com saucy/main Sources                  
Hit http://fi.archive.ubuntu.com saucy/restricted Sources                      
Hit http://extras.ubuntu.com saucy/main Sources                                
Hit http://fi.archive.ubuntu.com saucy/universe Sources                        
Hit http://fi.archive.ubuntu.com saucy/multiverse Sources                      
Hit http://extras.ubuntu.com saucy/main i386 Packages                          
Hit http://fi.archive.ubuntu.com saucy/main i386 Packages                      
Hit http://security.ubuntu.com saucy-security Release.gpg                      
Hit http://fi.archive.ubuntu.com saucy/restricted i386 Packages                
Hit http://fi.archive.ubuntu.com saucy/universe i386 Packages        
Hit http://fi.archive.ubuntu.com saucy/multiverse i386 Packages      
Hit http://fi.archive.ubuntu.com saucy/main Translation-en           
Hit http://security.ubuntu.com saucy-security Release                
Hit http://fi.archive.ubuntu.com saucy/multiverse Translation-en               
Hit http://fi.archive.ubuntu.com saucy/restricted Translation-en               
Hit http://security.ubuntu.com saucy-security/main Sources                     
Hit http://fi.archive.ubuntu.com saucy/universe Translation-en       
Hit http://fi.archive.ubuntu.com saucy-updates/main Sources          
Ign http://ppa.launchpad.net saucy/main Translation-en_US            
Hit http://fi.archive.ubuntu.com saucy-updates/restricted Sources              
Hit http://fi.archive.ubuntu.com saucy-updates/universe Sources                
Ign http://ppa.launchpad.net saucy/main Translation-en               
Hit http://fi.archive.ubuntu.com saucy-updates/multiverse Sources              
Hit http://security.ubuntu.com saucy-security/restricted Sources               
Hit http://fi.archive.ubuntu.com saucy-updates/main i386 Packages
Hit http://fi.archive.ubuntu.com saucy-updates/restricted i386 Packages
Ign http://extras.ubuntu.com saucy/main Translation-en_US
Hit http://fi.archive.ubuntu.com saucy-updates/universe i386 Packages          
Hit http://fi.archive.ubuntu.com saucy-updates/multiverse i386 Packages        
Ign http://extras.ubuntu.com saucy/main Translation-en
Hit http://security.ubuntu.com saucy-security/universe Sources                 
Hit http://fi.archive.ubuntu.com saucy-updates/main Translation-en             
Hit http://fi.archive.ubuntu.com saucy-updates/multiverse Translation-en
Hit http://fi.archive.ubuntu.com saucy-updates/restricted Translation-en
Hit http://security.ubuntu.com saucy-security/multiverse Sources               
Hit http://fi.archive.ubuntu.com saucy-updates/universe Translation-en         
Hit http://fi.archive.ubuntu.com saucy-backports/main Sources
Hit http://fi.archive.ubuntu.com saucy-backports/restricted Sources
Hit http://fi.archive.ubuntu.com saucy-backports/universe Sources
Hit http://security.ubuntu.com saucy-security/main i386 Packages
Hit http://fi.archive.ubuntu.com saucy-backports/multiverse Sources
Hit http://fi.archive.ubuntu.com saucy-backports/main i386 Packages
Hit http://fi.archive.ubuntu.com saucy-backports/restricted i386 Packages
Hit http://fi.archive.ubuntu.com saucy-backports/universe i386 Packages
Hit http://fi.archive.ubuntu.com saucy-backports/multiverse i386 Packages      
Hit http://security.ubuntu.com saucy-security/restricted i386 Packages         
Hit http://fi.archive.ubuntu.com saucy-backports/main Translation-en           
Hit http://fi.archive.ubuntu.com saucy-backports/multiverse Translation-en
Hit http://security.ubuntu.com saucy-security/universe i386 Packages
Hit http://fi.archive.ubuntu.com saucy-backports/restricted Translation-en
Hit http://fi.archive.ubuntu.com saucy-backports/universe Translation-en       
Hit http://security.ubuntu.com saucy-security/multiverse i386 Packages         
Hit http://security.ubuntu.com saucy-security/main Translation-en              
Hit http://security.ubuntu.com saucy-security/multiverse Translation-en
Ign http://fi.archive.ubuntu.com saucy/main Translation-en_US
Hit http://security.ubuntu.com saucy-security/restricted Translation-en
Ign http://fi.archive.ubuntu.com saucy/multiverse Translation-en_US
Ign http://fi.archive.ubuntu.com saucy/restricted Translation-en_US
Ign http://fi.archive.ubuntu.com saucy/universe Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-updates/main Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-updates/multiverse Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-updates/restricted Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-updates/universe Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-backports/main Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-backports/multiverse Translation-en_US
Ign http://fi.archive.ubuntu.com saucy-backports/restricted Translation-en_US
Hit http://security.ubuntu.com saucy-security/universe Translation-en
Ign http://fi.archive.ubuntu.com saucy-backports/universe Translation-en_US
Ign http://security.ubuntu.com saucy-security/main Translation-en_US
Ign http://security.ubuntu.com saucy-security/multiverse Translation-en_US
Ign http://security.ubuntu.com saucy-security/restricted Translation-en_US
Ign http://security.ubuntu.com saucy-security/universe Translation-en_US
Reading package lists... Done
jaakko@jaakko-VPCEB1S1E:~$ sudo apt-get install sagemath-upstream-binary
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package sagemath-upstream-binary is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'sagemath-upstream-binary' has no installation candidate
jaakko@jaakko-VPCEB1S1E:~$ 

2 Answers 2

5

I managed to install it on an Ubuntu 14.04 64 bit fresh install from the PPA. However, I replaced apt-get by aptitude. That is,

sudo apt-add-repository -y ppa:aims/sagemath
sudo aptitude update
sudo aptitude install sagemath-upstream-binary

I wonder wheter the trick was a) 14.04 instead of 13.10, b) 64 bit (amd64) instead of 32 bit (i386), c) aptitude instead of apt-get or d) time healing all wounds.

2
  • 1
    As of now, the PPA has an amd64 version but not a i386 version of sagemath-upstream-binary. So, I suspect the answer to your question is (b).
    – rgrig
    Apr 12, 2015 at 20:13
  • This PPA is no longer maintained.
    – hola
    Apr 11, 2018 at 13:34
1

I only saw this post now but the PPA doesn't seem to work, I just downloaded the latest binary version of Sage Math 6.1.1 and installed it for all users(only me) on my computer using symbolic link. I am using Ubuntu 14.04 Trusty. Perhaps you can use the cloud version.

http://www.sagemath.org/download-linux.html

and the help file

http://www.sagemath.org/doc/installation/binary.html#linux-and-os-x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.