0

I've recently encountered problems with my netbook when I dabbled with the graphics driver. I recently tried to install the "Cedar Trail in DKMS Format" through Additional Drivers in system settings and got that error in installation that somehow screwed my system up so it can't boot. After numerous hours on google and trying out the suggested fixes, I finally just settled on reinstalling Ubuntu. However now I have these problems:

  1. After re-installing Ubuntu, the log-in screen after waking from suspend is filled with multi-colored vertical lines with a square white box where the mouse pointer should have been. I've encountered this error during my original installation but was able to fix it, although already forgetting how since its been almost a year. I've tried adding nomodeset, acpi_backlight=vendor, removed quiet splash -- everything, but the outcome is the same. I have no choice but to Ctrl +Alt+ F1 and either restart lightdm or to just sudo poweroff or reboot.

  2. Attempting to try to fix above problem, I've resorted to again installing the graphics driver. I downloaded cedarview-graphics-drivers on synaptic (that goes with cedarview-drm) and the cedarview vaapi driver and now my netbook won't boot. It gets stuck in the boot screen with the Ubuntu logo with the five dots under it and the message that /tmp is not ready, and even if I press S or M to skip or manually restore, nothing happens. Also, cannot continue with the failsafe graphics on recovery, and already ran file system check and broken dependencies. Removing cedartrail does not do anything either. Could there be a way to fix it without having to reinstall Ubuntu again?

I just want my netbook to go back as it was during the original installation, with the log-in screen fixed. Although now I can't boot unless in recovery mode.

My netbook is an Acer Aspire D270 (Intel Atom N2600, so it's Intel GMA 3600), running on Ubuntu 12.04.04 32-bit.

1

Couldn't wait so I tried out stuff and finally solved my problem. I eventually just reinstalled ubuntu and this time, I'm not activating cedarview.

  1. Okay, so add this on the GRUB_CMDLINE_LINUX_DEFAULT line

    nomodeset acpi_backlight=vendor
    
  2. And this, after GRUB_CMDLINE_LINUX

    acpi_osi=Linux
    
  3. Update grub.

    After this, I only get a black screen (with the backlight on) after waking from suspend. Note that only the screen is black, but the system has woken up and is working so it is possible to just blindly log in, open terminal and command to reboot or poweroff.

  4. So my next fix was to check if this works and if my system resumes after that. Ran terminal and typed sudo pm-suspend --quirk-vbemode-restore. It did not, and so I tried this out:

    sudo pm-suspend -quirk-vbemode-restore
    

    and my system came back just as I had left it. To use this option, run (i know I have gma3600 but it works anyway):

     gksudo gedit /etc/pm/config.d/gma500
    
  5. then add this code:

    ADD_PARAMETERS='-quirk-vbemode-restore'
    

Suspend now works normally for me.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.