2

The update notifier doesn't notify me when updates are available. Sometime ago I had a similar problem and this worked:

sudo rm /var/lib/update-notifier/dpkg-run-stamp
sudo rm /var/lib/update-notifier/updates-available
sudo rm /var/lib/apt/periodic/update-success-stamp

But it does't work in this case:

sudo /usr/lib/update-notifier/update-motd-updates-available --force
E: Unknown error: «<class 'KeyError'>» ("The cache has no package named 'wine1.7-i386'")

I also tried:

sudo apt-get clean
sudo apt-get auto-clean
sudo apt-get clean all

But it didn't work either.

Anyone knows how to fix it?

moray33@Jose:~$ sudo apt-get check
Reading package lists... Done  
Building dependency tree       
Reading state information... Done  
moray33@Jose:~$ sudo dpkg --audit
moray33@Jose:~$ dpkg -S /var/lib/apt/periodic/ /var/lib/update-notifier/
apt: /var/lib/apt/periodic
update-notifier-common, ubuntu-release-upgrader-core, update-manager-core: /var/lib/update-notifier
  • Why you removed those files???? – Braiam Jan 22 '14 at 16:17
  • They suggested me to remove them in order to solve a similar problem I had some time ago (and it worked). – moray33 Jan 22 '14 at 16:22
  • Edit your qeustion and include the output of sudo apt-get check sudo dpkg --audit and dpkg -S /var/lib/apt/periodic/ /var/lib/update-notifier/ – Braiam Jan 22 '14 at 16:34
  • Output included. – moray33 Jan 22 '14 at 16:41
  • Why are you trying to execute /usr/lib/update-notifier/update-motd-updates-available? – Braiam Jan 22 '14 at 16:46
4

Hi I am new to ubuntu so I am trying it out, I got to know wine because I wish to use Dreamveaver but with no success, I even tried to install some .dll from winetrick and tried to remove some because apparently wine has made my computer into a "windows server"(that's what an error message said). Anyway after doing those things,I had the same problem as yours until this morning.

E: Unknown error: «<class 'KeyError'>» ("The cache has no package named 'wine1.7-i386'")

As I had "lost" wine1.7-i386, I tried to reinstall it so I ran

sudo apt-get update
sudo apt-get install wine1.7-i386

then it updated my wine1.7 and wine1.7-amd64 and also installed wine1.7-i386. hey also while downloading wine1.7-i386 it aborted for some forgotten reason. but I retyped the same command and it continued. And now the error message is gone. Hope that will help you.


PS: I never used sudo rm /var/lib/update-notifier/dpkg-run-stamp or and the rest.

  • I still see the error message after doing what you suggest. I tried sudo apt-get update && sudo apt-get install -y wine1.7-i386 and I get the messages wine1.7-i386:i386 is already the newest version., then wine1.7-i386:i386 set to manually installed., then 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.. I'm on Ubuntu 14.04.1 LTS. – Adam Monsen Jan 29 '15 at 15:32
0

What it worked for me is that I purged all Wine packages, and deleted all of these folders: HOME/.wine HOME/.config/menus/applications-merged/wine* HOME/.local/share/applications/wine HOME/.local/share/desktop-directories/wine* HOME/.local/share/icons/ And then installed again Wine and it seems I have no longer this issue.

  • The issue came back again, so it's not solved. – moray33 Mar 29 '14 at 12:24
0

I had the same problem and came t this solution. I uninstalled it and then reinstalled it. I tried upgrading wine1.7-i386 but it said I was at the latest version.

sudo apt-get remove --purge wine1.7-i386
rm -r ~/.wine
sudo apt-get install wine1.7-i386

Source: http://ubuntuforums.org/showthread.php?t=810815

0

This worked for me:

sudo ( apt-get update && sudo apt-get dist-upgrade )

then log out and log in again.

Though see also https://askubuntu.com/questions/531248/why-is-there-a-persistant-apt-error-indicator-when-i-have-since-repaired-my-syst

-2

I have the same issue. I just run de command

sudo apt-get upgrade

and the problem solve by it self.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.