Ok, I am mostly a windows user but for for learning RoR at work, I had to get used to a mac . Once I did I found that I enjoyed it, especially the terminal, I could load up projects in moments what would take a fair bit longer on windows. Now Obviously Mac isn't Linux but they both work similarly at least in regards to things like terminal (correct me if I'm wrong).

So I could have that same flexibility at home I installed Ubuntu on a separate SSD, but things started to go wrong. I installed gnome 3.1 and my cursor vanished, but I fixed it. However I was still stuck with unity (Hate this desktop) and doing 'gnome-shell --replace' didn't do anything and my mouse cursor on the login screen was invisible so I couldn't change it by clicking on it.

I installed ZSH as my terminal shell (like I had on mac) and Oh-myz-zsh but nothing I did in the zshrc file did anything, none of the theme stuff changed, none of the plugins I selected worked.

None of the terminal commands worked i.e. rails = no command found, git = no command found, subl (sublime text editor) = no command found. And then, when I tried closing down, everything went wonky and now it loads up all funny, ( e.g. the text menu on the terminal window vanishes and re-appears constantly).

Now, I need to get this working for work related purposes so can some one explain to me, how to:

1) get Zsh and oh-my-zsh working properly (I honestly prefer zsh to bash)

2) install ruby, rails, git, sublime and get all the nice terminal commands working

3) get gnome working

4) anything else you might recommend

To any that help me, Thank you very much, this has been driving me nuts like nothing else.

closed as too broad by Radu Rădeanu, Eric Carvalho, kiri, karel, Braiam Jan 23 '14 at 13:28

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Check github.com/railsinstaller/railsinstaller-nix – mreq Jan 22 '14 at 15:15
  • Read help.ubuntu.com/community/AptGet/Howto about how to install software on Ubuntu... Or use the Software Center – s3lph Jan 22 '14 at 15:35
  • Yeah, see neither of those are helpful, the first is for OSX not Ubuntu and the other doesn't answer my question at all, I know how to use apt-get, and that's not the problem. The problem is that there is most likely a way to install all of those things that needs to be done in the correct way and I'm just not doing it that way because I'm un-aware of it. – user238659 Jan 22 '14 at 17:09
  • EDIT: Yeah, sorry I only saw OSX and didn't see Linux in the title. So what else does it do? does it make all the Terminal commands and so on work? I mean, Ruby worked but Git and rails didn't. – user238659 Jan 22 '14 at 18:16

1) You'll have to provide more info as to what exactly is the problem. Are you even running zsh ? ie what is the output of ps -p $$ ? How did you install it ?

2) To manage my ruby versions and my gems I use rvm. See for instance here how to set it up and use it. Once it's installed getting rails is as easy as gem install rails. Git is in the repositories, you say you know how to use apt-get so you should know that you just need to sudo apt-get install git. Sublime text is not in the repos, you can download and install it from here.

3) How did you install Gnome shell ? This tutorial will show you how to install Gnome 3.10.

  • 1) I used apt-get install zsh and then followed the infomation on the git repo to install oh-my-zsh. – user238659 Jan 22 '14 at 20:19
  • 1) I used ‘apt-get install zsh’ for zsh and followed the information present on it’s git hub repo to install oh-my-zsh. 2) I use RVM and I used ‘gem install rails’ for rails though, is that why rails commands didn’t work? I downloaded sublime from the website but I’m unaware of how to get commands to it to work. 3)I searched and followed what some one else did, though admittedly I very stupidly didn’t make note of it, but it was mostly update and then install gnome and so on. – user238659 Jan 22 '14 at 20:32
  • I apologise for the bad formatting but I can't go to the next line, pressing enter just submits, also a chunk at the end had to go. The bit that would have been at the end of the last comment was: The main problems was that the commands in terminal that you expect didn’t seem to work after installing them, i.e. ‘rails init’ or ‘git init’ and so on weren’t recognised. I’m probably going to have to re-install Ubuntu to fix the weirdness. – user238659 Jan 22 '14 at 20:35
  • 1) Maybe you have installed zsh but not made it your default shell yet, so new terminal windows open in bash. Type zsh while in bash to launch it, and to make it default use chsh -s /bin/zsh and then logout and login again. If that's not the problem maybe this question can help you : askubuntu.com/questions/132050/…, but I probably can't help any further because I don't use zsh. Also I'll edit the answer because echo $SHELL gives you your preferred shell and not the one you're currently in – Samuel Peter Jan 22 '14 at 20:56
  • 2) gem install rails should have worked (that was a typo sorry), and it's very weird that you're not able to use git. What is the result of echo $PATH ? Maybe the PATH isn't set right when you switch to zsh ? For the rails thing, maybe you're not currently using the gemset you installed it in ? What is the output of rvm gemset list ? – Samuel Peter Jan 22 '14 at 20:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.