I'm attempting to follow the steps here to change the the default application that opens a Blender file.

I input the command mimeopen -dmime my_file.blend and when prompted for the application, I input the path to a new version of Blender. Note: I have used this method once to successfully associate .blend files with an older version of Blender, but I can't switch the association now. It just outputs cancelled.

~/Desktop $ mimeopen -d my_file.blend
gtPlease choose a default application for files of type application/x-blender

1) home  (home-usercreated-1)
2) Other...

use application #/home/garrett/blender-2.69-2aeb492-linux-glibc211-x86_64/blender
~/Desktop $

I also tried using this method to change associations of .txt files to /usr/bin/gedit with the same result.

What's going wrong? I'm on Ubuntu 13.10 and using mimeopen 0.15 (the default).


You can see from mimeopen's source (I searched for "Cancelled"), it's expecting a number.

If you want to specify an application, in your case, specify 2 (for "Other...") and then specify the command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.