Since I upgraded to ubuntu 13.10 (from 13.04), it's not always possible to switch users: a black screen and an arrow are displayed when an attempt is made to switch from a logged-in account to another one.

My desktop is Unity. I haven't installed another one. Display manager is lightdm.

The system does not freeze, it's possible to escape by going into a console with Ctrl-alt-F1 and kill the current session to return to the login screen. Still, it's annoying.

I have tried rebooting after removing .Xauthority files, including /var/lib/lightdm/.Xauthority, but the problem comes back after a day or two.

Do you have any idea what's going on ?


I struggled with this problem since upgrading to 13.10 in October. I believe I've finally solved it by upgrading to the development version of lightdm (1.9.7). https://launchpad.net/ubuntu/+source/lightdm/1.9.7-0ubuntu2/+build/5582036

To determine if lightdm is the source of your problem you could try replacing lightdm with gdm. If things go smoothly with gdm then continue with gdm or try the dev version of lightdm.

|improve this answer|||||
  • Thanks for this. I am trying out gdm, it seems to go fine. – epsicot Mar 17 '14 at 10:25

I have this issue in 12.04.4; but there's no need for me to kill the session.

So, when I Ctrl-Alt-F[number of session running I want to switch into], I get the black screen and frozen mouse pointer; but all I do is simply 'blindly' enter my password (for that session I'm wanting in to) (I just type in the password and then press carriage-return/Enter) and the session I want pops up and off I go. You might like to try that.

I've noticed that, sometimes, if my computer is busy and, thus, slow to respond, the switch-user/log-into-current-session box does, briefly, appear before being blacked out (the blacking out is the screensaver, I think); so, just imagine the dialogue widget (box) is on the screen—by default, the text cursor is in the password box; tabbing switches focus to (takes you to) the switch-user button; tabbing again switches focus to the log-in-to-current-session-you're-coming-from; tabbing again switches focus back to the text-entry box (shift-tabbing does the above but in reverse).

(The black-screen issue also occurs when I launch the 'Switch User Account...' facility; but, this time, if I move the mouse, the box appears.)

As I said, I think it's a screensaver issue; the running sessions, other than the one one is in, get locked, after all.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.