2

I'm running Windows 7 normally on my Acer laptop, and it works like a charm. However, whenever I boot up Ubuntu, the network card doesn't even seem to exist.

I've looked for hours for a solution, to no avail.

These are some specs of the chip:

Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

What steps do I have to take to get some kind of network connection? The networking was the one thing I liked about Ubuntu, however, this is kind of a turn-off.

I have tried running the "Additional Drivers" tool but it did not work.

  • 1
    Have you tried plugging in the ethernet and running "additional drivers"? – Jorge Castro May 7 '11 at 14:57
  • I don't know what "additional drivers" is, but I will go try that. – Ian Cordle May 7 '11 at 16:05
  • Okay, I tried that, and I get no results. It updated my Natty, but no change in network status. Is there a place where I could get a driver? Or how could I use ndiswrapper? – Ian Cordle May 7 '11 at 17:35
2

Googling around - as you have found, some of the Atheros drivers in the 2.6.38 kernel are broken.

This website suggests the following workaround until the kernel is fixed:

sudo su
echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9.conf

Then reboot

Note - I've seen other websites that say that the file should be ath9k.conf. So if the above doesnt work, try

sudo su
echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

Remove the ath9.conf / ath9k.conf file when a new kernel is released (assuming of course the new kernel fixes this issue).

  • Okay, I've given up at this point, but I might as well try it. I'll take it for a test spin later. – Ian Cordle May 29 '11 at 12:46
  • @IanVal - its perhaps also worth when testing, disabling any WEP/WPA protection you have in your router. If you can get it working unprotected, then try enabling WEP, then WPA then WPA2 etc. – fossfreedom May 29 '11 at 13:25
  • Thank you for the help! For me, this line didn't work. I typed it like this: sudo su then echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9.conf – st3fUn Jul 13 '11 at 16:12
1

I was able to solve this with the solution here, which is to manually update the kernel to 3.6: Artheros AR9287 Txpower

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.