2

This question already has an answer here:

I have been trying to install the ubuntu developer environment so that I may begin gaining practice in app development. But once I try to install ubuntu-sdk I get the following error:

The following packages have unmet dependencies:
ubuntu-sdk : Depends: ubuntu-html5-container but it is not going to be installed

for which I then proceed to insert the command:

sudo apt-get install ubuntu-html5-container

in which I then receive the following error message:

The following packages have unmet dependencies:
ubuntu-html5-container : Depends: qtdeclarative5-ubuntu-ui-extras-browser-plugin but it is not installable

at which point I would feel logical to insert the command:

sudo apt-get install qtdeclarative5-ubuntu-ui-extras-browser-plugin

and my new error message is:

Package qtdeclarative5-ubuntu-ui-extras-browser-plugin is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or is only available from another source

I have no idea what I'm doing wrong and I have updated my repository libraries several times and still nothing. Could someone please tell me what it is that I'm doing wrong? Why isn't this working like it should?

marked as duplicate by karel, Avinash Raj, BuZZ-dEE, Eric Carvalho, mikewhatever Feb 1 '14 at 10:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • the suggested ticket has a great, general purpose answer, but the issue reported here is very specific. I guess something got broken in the package dependencies, because we installed the SDK some times ago on ubuntu just following the steps from the website (the same steps suggested by @Avinash Raj) and that time it worked fine. – sergico Jan 31 '14 at 8:30
  • I have the same problem, so this question isn't specific. – Timur Fayzrakhmanov Oct 5 '14 at 7:32
3

I have the very same issue trying to install ubuntu-sdk on a new VM today The VM is running Ubuntu 12.04 LTS 64bit

Here how I solved the issue:

  • downloaded the packages:

qtdeclarative5-ubuntu-ui-extras-browser-plugin

qtdeclarative5-ubuntu-ui-extras-browser-plugin-assets

  • installed manually the packages dependencies:

sudo apt-get install libqt5core5

sudo apt-get install libqt5gui5

sudo apt-get install libqt5qml5

sudo apt-get install libqt5quick5 libqt5sql5 libqt5webkit5 libqt5sql5-sqlite

sudo apt-get install libqt5webkit5-qmlwebkitplugin qtdeclarative5-qtquick2-plugin

sudo dpkg -i qtdeclarative5-ubuntu-ui-extras-browser-plugin-assets_0.22+13.10.20131011.1-0ubuntu1_all.deb

sudo apt-get install qtdeclarative5-ubuntu-ui-toolkit-plugin

sudo apt-get install qtdeclarative5-unity-action-plugin

sudo apt-get install qtdeclarative5-window-plugin

sudo dpkg -i qtdeclarative5-ubuntu-ui-extras-browser-plugin_0.22+13.10.20131011.1-0ubuntu1_amd64.deb

Finally run the command to install the skd:

sudo apt-get install ubuntu-sdk

That worked fine for me :)

  • 2
    I use 13.04 and it worked like a charm – ahhmarr Feb 1 '14 at 10:00
  • unfortunately we have to stick to 12.04 as it is the currrent LTS version :) – sergico Feb 1 '14 at 13:17
1

Try only this command on terminal,

sudo apt-get install aptitude; sudo aptitude install ubuntu-sdk
  • that's what I did, and I got the very same error reported by @HaveYouMetRandy – sergico Jan 30 '14 at 14:54
  • but it works for me.Enable the universe repository and update it,then run the above code. – Avinash Raj Jan 30 '14 at 14:58
  • I believe you, and actually those are the command on the SDK webpage, but that does not worked for me either. – sergico Jan 30 '14 at 15:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.