I've been overlooking this problem for several hours and I'm starting to get crazy. I have a few folders sharing with users. When setting up the permissions the folders are being displayed ok, but can't acces the subfolders (or see the content).

What I've been trying:

chmod -R 770 test

As I said, I can acces the content of the folder test, but can't acces test > test 1 > test 2 >. How do I apply these settings to all enclosed folders and files?

Kind regards,

[EDIT] When doing chmod -R 770 test I get the following output:

drwxrwx--- 3 server server 4069 jan 20 17:25 test1
  • You need execute permissions (which you are setting to 0) in order to list the contents of a folder. (See, eg, content.hccfl.edu/pollock/aunix1/filepermissions.htm ) – chronitis Jan 20 '14 at 15:05
  • Thanks chronitis, but how do I change settings to following: Owner and usergroup can Read, write, execute, and others can't do anything? – rwzdoorn Jan 20 '14 at 15:25
  • Post the output of ls -l test and ls -ld test. – falconer Jan 20 '14 at 15:47
  • Hi Falconer, Out put is: drw-rw-r-- server server 4069 jan 20 15:38 test – rwzdoorn Jan 20 '14 at 16:01
  • @rwzdoorn And did you ran the chmod command already? Because it says that the test folder is still readable by others. Your username is server? Or you run the command with sudo? – falconer Jan 20 '14 at 16:12

Okay, problem solved:

Just a small thing, never use the GUI users and groups option, just use your terminal.

What I did (and works):

sudo -s
[your root password]

Create a group and add users:

sudo groupadd [groupname] * creates a group
sudo usermod -a -G [groupname] [username] *add the user to the group

Make a folder executable for a group and give rights:

sudo chgrp -R [groupname] [path/to/folder] * Gives usergroup also access
sudo chmod -R 770 [path/to/folder] * Gives rights to owner, usergroup and other
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.