I have just copied my Ubuntu 64bit ISO into my USB Flash Drive and booted from there. It's my first time using a Linux distro, right now I'm using Windows 8 and writing this from the Try Ubuntu option. I'm just trying to install Ubuntu along with Windows 8, to keep both and select which one I want to start when I turn on my machine. I know there are similar questions, but no one helped me.

I execute the GParted program to make a partition of the hard disk. This is what I have.

enter image description here

Can you see the red icon at the /dev/sda2 partition? That's the Windows 8 system, and the sda1 is the Windows 8 booter (as far as I know). I do right-click on the sda2 partition and try to reduce the size to something like 700mb to let 300mb to my new Ubuntu system. But it's locked. It doesn't let me to resize or touch anything. It let me when resizing the sda1 partition but not the one with the red icon.

This is what I'm getting while doing Right-click > Information on /dev/sda2.

enter image description here

I'm very very new in this Linux-based world, so, how can I make a new partition to install this beautiful operating system?

Thanks a lot.


This problem has been solved according to Archlinux forums

you have to run chkdsk /fin cmd inside Windows


If you right click on the partition in question and choose "information", the window that appears should explain the reason behind the warning symbol, which I imagine will tell you why you cannot resize it.


Looks like your Windows file system is a little inconsistent. Boot back into Windows, and check the drive for errors (find the drive in (My) Computer, right-click, check for errors is usually in the tools tab or similar.) If it is your system partition you may have to schedule the disk check to be done at the next reboot.

Alternatively if you press F8 on Windows start-up to get into the boot/recovery options, you can go into the repair/recovery mode and check the disk from there - you may need to do it manually from the command line with chkdsk (sorry I can't be more helpful here - I haven't encountered Windows 8 yet!)

Once Windows has cleaned up the filesystem, hopefully gparted will be prepared to resize it for you :)

  • You are right. Please see my updated question. – cdonts Jan 20 '14 at 1:18
  • Answer updated accordingly :) – Steve Dee Jan 20 '14 at 1:28
  • I solved this with the @microarm15 answer, but +1 for your dedication and help! Thanks! – cdonts Jan 20 '14 at 1:59

To remove the red-mark on the ntfs partition,

  • click on the gparted option in the menu bar and select Refresh Devices.


  • Boot into windows and make a restart (not shutdown).


  • Check for bad blocks in that partition using chkdsk in windows or ntfsfix utility in Ubuntu.

  • The third option works, as @microarm15 said. +1 Thanks! – cdonts Jan 20 '14 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.