I get this error when I try installing shutter:

The following packages have unmet dependencies:

$ sudo apt-get install -f shutter 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 shutter : Depends: libxml-simple-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I checked out the other Ask Ubuntu thread but the solution mentions mirrors but he has not elaborated further.

  • How did you install shutter? – Alvar Jan 19 '14 at 17:17
  • sudo apt-get install shutter. Though, after your answer, I added the PPA and tried the software center too but it did not fix it. – callmekatootie Jan 19 '14 at 17:25
  • see this question for how you can solve unmet dependencies, askubuntu.com/q/140246/10698 – Alvar Jan 19 '14 at 17:28
  • I suspect it has to to with the software ppa too - In my case, it says "NOT going to be installed" - I have only allowed important updates and no recommended updates. Is that causing this? – callmekatootie Jan 19 '14 at 17:31
  • install all updates and try again... – Alvar Jan 19 '14 at 17:32

According to shutters website it should be as simple as following the steps there.

  1. Add the PPA with, sudo add-apt-repository ppa:shutter/ppa
  2. update your source list with, sudo apt-get update.
  3. And install shutter with sudo apt-get install shutter.

When I installed shutter on my 13.04/13.10 I just used the software center.

does this work for you?

  • I added the PPA and even then I get the same error. If I use the software center, I get an error saying that package has unmet dependencies... – callmekatootie Jan 19 '14 at 17:24
  • what happens if you type sudo apt-get install -f shutter ? – Alvar Jan 19 '14 at 17:26
  • Same error. I have updated the question with the full error message, if that helps. – callmekatootie Jan 19 '14 at 17:29
  • @callmekatootie, have you solved out the issue ? I am also facing the same error messages. Even worse in mine case – Gurjit Mar 19 '17 at 10:31
  • @Gurjit Its many years back. I don't remember it but most likely I solved it my installing the dependencies myself manually. I say so because I have used Shutter every time and don't remember using anything else. – callmekatootie Mar 20 '17 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.