2

I've been using Sublime Text 2 quit a bit lately and want to make it as easy to launch as Terminal.

I've done the following so far:

  1. I went into System Settings > Keyboard > Shortcuts > Windows and disabled the shortcut for Toggled Shaded (Ctrl + Alt + S).
  2. I used gconf-editor to add <Control><Primary><Alt>S under apps/metacity/global_keybindings/run_command_1 and pointed it to /usr/bin/sublime under apps/metacity/keybinding_commands/command_1.
  3. I went into dconf-editor and changed the Toggle Shadows shortcut to <Control><Super>S under org/gnome/desktop/wm/keybindings.

I am still unable to launch Sublime with the shortcut Ctrl + Alt + S, and normal windows still keep being toggled with the shortcut. I'm using Ubuntu 12.04, any suggestions on what I am doing wrong?

  • I went back into System Settings > Keyboard > Shortcuts > Windows and changed the shortcut for Toggled Shaded to Ctrl + Super + S. Now Ctrl + Super + S causes a toggle state, but Ctrl + Alt + S doesnt do anything. I am not sure if this has something to do with the location I put in gconf-editor. I ran the "which sublime" command, which gave me "/usr/bin/sublime" as the result. – Khanjan Desai Jan 19 '14 at 11:10
1

I solved this by going into the Shortcuts settings of Ubuntu (System Settings > Keyboard > Shortcuts) and simply creating a custom shortcut with the command /usr/bin/sublime, then double click on the "Disabled" area and pressing the Ctrl + Alt + S keys.

Changing anything in gconf-editor under both user & root access didn't change a thing.

  • Thanks for this. I couldn't figure out why an options dialog in Qt Creator was closing whenever I used Ctrl + Alt + S... I set "Toggle shaded state" to Ctrl + Alt + Shift + S to work around it. – Mitch Apr 28 '17 at 13:05
0

Hard to say what is going on without a deep study of your configuration. BUT try using gconf-editor to look at /apps/metacity/window_keybindings for "toggle_shaded". That generally is set to Ctrl+Alt+S. If you're not using the metacity window manager then this change will do nothing.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.