0

I've got a new installation of ubuntu running as a VM on server 2012. I've joined it to the domain using likewise open. I am able to us domain accounts to logon to the ubuntu desktop. I am having a problem mounting or connecting to the windows server however. I've tried using "Connect to server" to get to the share but I get an error "please verify your credentials". I've tried manually mounting the share using cifs, similar error "mount error(13) permission denied" I've used the same credentials I used to log in as well as the administrator credentials to mount this share. I have an installation of ubuntu server which was able to mount the share without a problem, using the same methods. The only difference is the server is not joined to the domain. I can ping the server and the domain.

The entry in fstab looks like this:

//SERVER-1/Music /mnt/music cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

does anyone have any ideas on this?

  • Have you installed cifs-utils as suggested in this Ubuntu Wiki article? – douggro Jan 18 '14 at 15:27
  • yes I did, I get output that mount.cifs is giving the error – Craig Smith Jan 18 '14 at 15:45
  • Though not recommended, put the credentials in the fstab entry rather than using the hash. Also, it could be the domain that's mucking it up; perhaps adding the domain to the entry? – douggro Jan 18 '14 at 15:51
  • I've tried putting the credentials in the fstab file with the same results – Craig Smith Jan 18 '14 at 15:53
  • I know that when I'm logging into our shares through AD at work that I have to use the domain as part of my username to authenticate: domain\username and the slash direction is important. Perhaps try that as part of your credential. – douggro Jan 18 '14 at 15:57
0

Below is my FSTAB line to mount on my desktop computer a USB drive that is attached to a (remote) router. Two points, you may need to identify the file system as "CIFS" and and you may need to include "sec=ntlm".

#Mount Western Digital Passport Drive On Router
//rt-n56u/sda1 /media/My_Passport cifs rw,sec=ntlm,guest,uid=1000,gid=34,iocharset=utf8,nofail 0 0
  • I've tried many "sec=...." that i've found on the net. Either I would get a general error or the permission denied error stayed. What is the nofail for? – Craig Smith Jan 18 '14 at 15:16
  • "nofail - Mount device when present but ignore if absent. This prevents errors being reported at boot for removable media." from wiki.archlinux.org/index.php/fstab – Steve R. Jan 18 '14 at 15:35
  • I finally found the Ubuntu page for the CIFS file system. Of course if you are not using CIFS, this would not apply. manpages.ubuntu.com/manpages/hardy/man8/mount.cifs.8.html – Steve R. Jan 18 '14 at 15:40
  • Could you post the link for it? – Craig Smith Jan 18 '14 at 15:43
  • Which link would you like? Here is the one to: Archlinux for FSTAB. Finally figured out how to use the formatting. – Steve R. Jan 18 '14 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.