Vanilla install of Ubuntu 13.10 on my MSI Wind U100. Intel graphics card I think.

Auto brightness flickers up and down, brightness hud display top-right also flickers. Interrupts input so need to restart to fix. Issue is triggered by attempting to adjust screen brightness by Fn+F4/Fn+F5, looking at the Brightness & Lock control panel in System Settings, or when laptop goes into battery saving mode (or whatever happens when the battery gets really low).

Very similar to this issue.

Issue is temporarily fixed with this code:

sudo chmod u-w /sys/class/backlight/acpi_video0/brightness

but issue returns after a restart. Prior to running this code the brightness settings do not appear in Brightness & Lock, after running this code the brightness settings appear but the brightness slider doesn't work.

Thank you!


The above solution worked brilliantly for me. Thanks to the author.

For those struggling with commands like me, open the terminal window by using the keys Ctrl + Alt + T or alternatively, click on the 'Search your computer and online sources' icon and search the applications for 'Terminal'.

When Terminal opens, type the command:

sudo gedit /etc/rc.local

Type in your password, the text editor will open and if its like mine have some text explaining the purpose of the file.

I simply inserted the following (copy and pasting it) into the text editor at the end:

chmod u-w /sys/class/backlight/acpi_video0/brightness

exit 0

Next, save the file and when you restart your computer the 'flickering brilliance' problem should be solved. Also if you have set it to do so, the screen should dim after the set period and not come back on again.

Good luck!

| improve this answer | |

I cannot help you to resolve the issue itself, but you can workaround by executing the mentioned command when booting. To do that simply put

chmod u-w /sys/class/backlight/acpi_video0/brightness

in /etc/rc.local. (Open with text editor of your choice and add the line before exit 0.) Remember, you need to have root rights to do that.
For adjusting the brightness have a look here: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/415023/comments/347

This is a known bug: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/415023 so I am afraid you will have to wait for the bug being solved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.