55

Every time my laptop boots, I am greeted by several "Ubuntu 13.10 has experienced an internal error" dialogs once the graphical desktop environment (whatever it's called) is displayed. Apparently the problem originates from plymouthd, which is (unsurprisingly) the daemon of the Plymouth boot splash application.

Has anyone ever found a fix for this type of issue?

(I would provide log excerpts but I'm not sure where to find them.)

  • 19
    How is this a duplicate??? – GOTO 0 Mar 23 '14 at 23:45
  • 5
    I agree, this is not a duplicate... – Serpentine Cougar Aug 19 '15 at 2:12
  • I would expect a duplicate accusation would go accompanied with a link to the duplicate to avoid any discussion – Jakke Dec 12 '15 at 2:37
  • 1
    There is nothing in the linked duplicate references plymouthd whatsoever. Vote to reopen. – WinEunuuchs2Unix Nov 4 '16 at 4:38
  • The bug report is here but unassigned: bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1542000 – 林果皞 Sep 14 '17 at 4:33
42

I have experienced the same error when I first installed Ubuntu 13.10 on the toshiba harman/kardon this week.

I solved the error with a single command:
Open a Terminal (Ctrl+Alt+T) and type:

sudo chown -R $USER: /lib/plymouth

Then all the permission issues are solved and the error is gone in the next boot.

  • 7
    Is 'user:user' supposed to my my user name? Or ...? As it stands the answer does not make sense to me. Thanks. – Art Swri Jul 18 '14 at 14:44
  • 4
    This solution doesn't look very clean. What to do if the computer is multi-user? – bli Aug 18 '14 at 16:36
  • 4
    Possible solution : sudo chmod 755 -R /lib/plymouth – Marko Feb 20 '15 at 21:26
  • 6
    It didn't actually worked for my multi-user system. I removed plymouth. To do that, open /etc/default/grub as root, and change line GRUB_CMDLINE_LINUX_DEFAULT="quite splash", to GRUB_CMDLINE_LINUX_DEFAULT="verbose " – Marko Feb 20 '15 at 22:20
  • 3
    This directory does not exist. – Zelphir Kaltstahl Feb 7 '17 at 21:21
29
sudo apt-get install plymouth-x11 

That did help me with the issue.

  • 12
    Tested and apparently working on Ubuntu 16.04 – 29axe Mar 17 '17 at 9:16
  • 1
    My case is very similar to @29axe's one, but I had to install only plymouth-theme-ubuntu-logo to avoid the problem on XUbuntu 16.04. – Беров Aug 29 '17 at 18:02
  • 1
    Not working on Ubuntu Gnome 17.04 – 29axe Sep 1 '17 at 13:09
  • 2
    Tested in Xubuntu 16.04.3 and working. – logoff Sep 6 '17 at 7:17
  • 3
    This happened to me on upgrading from 18.04 to 18.10, installing plymouth-x11 fixed it. – Stuart Nov 1 '18 at 11:02
7

A possible solution not mentioned here is to run:

sudo dpkg-reconfigure Plymouth

From: https://bugs.launchpad.net/ubuntu/+source/ubuntu-gnome-default-settings/+bug/1536771

  • 2
    Worked for me on 16.04 / Gnome (/lib/plymouth doesn't exist so the accepted answer does not apply) – Dominic Comtois Jan 19 '18 at 4:05
  • 3
    Worked for me on 18.10 / Gnome – Marcello Nuccio Jan 3 at 12:03
  • 1
    18.10 here, same problem on an upgrade, no /lib/plymouth nor /var/lib/plymouth - and this worked. Looks like a cleaner answer too. – Mark Williams Jan 10 at 14:01
  • 1
    worked for me for a while,trying again now ubuntu 18.10 – trond hansen Feb 1 at 9:36
  • 2
    I can also confirm that this worked on Ubuntu 18.10. Thanks a lot. – Pankaj Sanam Mar 10 at 6:00
3

I was experiencing this problem, also. I found out that /lib/plymouth did not exist. I installed plymouth using Synaptic (but you can use whatever pkg installer you like), and it fixed the problem.

There are other plymouth packages, but it looked like they were already installed for Ubuntu GNOME 16.04 64 bit, which is what I am using. I also discovered that when I installed Ubuntu GNOME 16.04 32 bit, I didn't have this problem. For me, it was only a problem with the 64 bit install.

2

In my case (Ubuntu Gnome 17.04), when I looked at the error details, it said the error was that /var/log/boot.log didn't exist. I just did 'sudo touch /var/log/boot.log' and the error went away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.