1

I have installed bootable ubuntu on hard disks but now I can not format them with Disk Utility program. When I try to format it says "One or more partitions are busy on /dev/sdb" for both hard disks. Is there any way to format these drives?

EDIT: With "Disk Utility" program when I select one of the hard drives It shows 3 volumes;

99 MB FAT
111 GB EXT4
9 GB UNKNOWN

I can not format this unknown volume.

With Gparted program, It doesn't shows Unknown volume only shows 111GB EXT4.

2
  • using gparted, right click on each partition and if one shows Swapoff, click Swapoff. It may be that even though you are using a DVD, the DVD may still using the swap area of the hard disk?? Once swap is off, you may be able to format the drive. Jan 17, 2014 at 22:22
  • @user3121023 there is no swapoff and I connect my externel drive after I boot ubuntu.
    – hellzone
    Jan 17, 2014 at 22:47

2 Answers 2

1

If the drive you want to format is also the drive you are using, you cannot change the format. Easiest way is to use a Live Boot disc and boot up inside the Trial area (where it gives you the option to install Ubuntu on the desktop). From there, you can format the drive, but be aware that formatting will erase data from the drive.

2
  • I am not using these drives. I am running ubuntu dvd. also I got 2 different hard drives and can not format both of them.
    – hellzone
    Jan 17, 2014 at 21:39
  • @Nihil777 you can add some info may be some relevant links to help the user. It will increase the quality of your answer.
    – sourav c.
    Jan 28, 2014 at 3:42
1

Use Gparted, burn it to disk,and boot the disk and format, you cannot format while working on Ubuntu, the hard disk is mounted

7
  • I am using ubuntu with my live Dvd and I can not format my external hard drive? Is it true?
    – hellzone
    Jan 17, 2014 at 21:46
  • @hellzone I don't know about that. But try gparted and your problem will be solved :)
    – Lynob
    Jan 17, 2014 at 21:48
  • @hellzone I see you're using gparted, did it work?
    – Lynob
    Jan 17, 2014 at 21:49
  • No gparted also gives error."Partition(s) 3 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes."
    – hellzone
    Jan 17, 2014 at 21:53
  • @hellzone reboot and try again. And did you unmount it?
    – Lynob
    Jan 17, 2014 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.