I am trying to install gedit 3.11.2 from:


for some reason, it does not work on my ubuntu 13.10

the file ./configure is not found.

i followed the steps in the README file:

  % tar Jxf gedit-3.11.2.tar.xz         # unpack the sources
  % cd gedit-3.11.2             # change to the toplevel directory
  % ./configure                 # run the `configure' script
  % make                    # build gedit
  [ Become root if necessary ]
  % make install                # install gedit

but then, the configure is not found. Am I missing something here?

  • yep, no configure file. You need to file a bug report with the maintainers. You might be able to run the autogen.sh . Try running chomd a+x autogen.sh && autogen.sh. then continue with ./configure ... – Panther Jan 17 '14 at 19:51

You should get the package from:


You might missing some lib. You can get them by installing them:

sudo add-apt-repository ppa:ricotz/testing
sudo apt-get update

sudo apt-get install intltool
sudo apt-get install itstool
sudo apt-get install libxml2 libglib2.0-dev libxml2-dev libxml2-utils
sudo apt-get install libxml2-dev
sudo apt-get install libgtksourceviewmm-3.0-dev
sudo apt-get install libpeas-1.0-0 libpeas-dev
sudo apt-get install gsettings-desktop-schemas-dev   
sudo apt-get install libgtkspell3-3-dev libgtkspell3-3-0 libgtksourceview-3.0-dev
sudo apt-get install gtk+3.0
sudo apt-get install gir1.2-gtk-3.0

I had an issue getting gtksourceview, I had to install it manually:


same deal:

sudo make install


Then, once everything is completed, you can run in the gedit folder:

sudo make install

NOTE: you might some graphic issues with the new GTK library. Check you drivers (nvidia or ati for example) or play with the "appearance" settings.

  • 2
    I've always liked "apt-get build-dep" to install dependencies so in this case "apt-get build-dep gedit". It will get all the dependencies you need. Of course it only knows about dependencies for the version in the ubuntu repo, but I find it to usually get right set. – Joe Jan 17 '14 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.