I bought Lenovo laptop couple of days ago, it comes with original windows 8. I formatted the entire hard disk and installed windows 8.1 pro instead and made 4 partitions

file systems - primary. c - primary. d, e, f - logical extended partitions.

I left about 40GB space to install ubuntu 12.04 lts ... I disabled fast boot, I chose legacy boot from the bios ... I put the ubuntu on the flash drive and loaded loaded into the live mode successfully, I start the installation and I have two options for the partitioning

  • erase everything
  • something else

I click on something else and it shows my entire hard disk and it is empty 1tb free space.

It does not see the windows at all. If I close the installation and go through the folders I can navigate to the windows partitions normally, the GParted shows only hard disk and it is free too.

So I cannot install it ... it is driving me crazy for the past three days ... I tried different versions of ubuntu 12.04 lts, 13.10 ... 32bits ... 64bits

and all the same thing.

Please please please help me.

Oh the hard disk is 1tb hdd - 8gb ssd (hybrid disk). Thank you very much in advance.

  • please post a snapshot (from Windows' Disk Management or Ubuntu's GParted) showing the your partitioning layout.. – precise Jan 17 '14 at 5:58

I am not sure this will work or not. But at first format all the partition using ntfs file system using Windows bootable disk and the create partition and then install Windows if you want then again plugin Ubuntu bootable disk and install Ubuntu. Make sure to select the correct partition.

And select Ext4 file system for the partition in which you are installing Ubuntu. And install the Ubuntu and it should works fine.

  • I tried that, I formatted the entire hard disk, and installed Windows. Then I loaded ubuntu but does not show any partitions, it shows an empty hard disk. – user236724 Jan 17 '14 at 4:58
  • can you try changing the ubuntu installation media that you are using now. – Sudeep Acharya Jan 17 '14 at 4:59
  • The flash drive my only option, this lenovo comes with no optical drive. Do you think if I try to install Windows 7 instead of Windows 8 then install ubuntu would solve the problem? ... just random thoughts haha – user236724 Jan 17 '14 at 5:00
  • can you use dvd/cd drive? – Sudeep Acharya Jan 17 '14 at 5:02
  • No it does not have a CD/DVD ROM, and I do not have an external one. – user236724 Jan 17 '14 at 5:03

You don't want to make partitions in Windows. First, reinstall windows onto the whole drive. Then just shrink the size of the Windows partition and leave the now unpartitioned "extra" space alone.

Then when you run the Ubuntu installer (I think you have to use 64 bit version if you are dual-booting with Windows 8?), click on "something else" and find your unpartitioned space - should be something like /dev/sda[some number] and the size should be close to the unpartitioned space you created in Windows.

Click that and create a partition, allocate your 40 gig. Partition type ext4. Then find the same space that was unpartitioned (/dev/sda-whatever) and create partition /home, type sda4. /home should be 40 gigs minus the size of your swap space, which depends on your hardware but if you're using a current-generation Lenovo 4 gigs or so is probably plenty, though some people say to go all the way up to 16.

In the remaining unpartitioned space create a 3rd partition and choose SWAP as the type. Some installers create swap automatically (at least I think mine for 13.04 did this), if so leave it alone.

Keep the bootloader at default, probably /dev/sda. Don't fool around with it.

Then you should be good to install.

The key point here is Don't Let Windows Make Partitions For You, Make Partitions in the Ubuntu Installer. What are you thinking, letting Windows partition your machine? Of course it's not working!

  • Hello, thank you so much for your response. No I did not make the partitions through the windows. I left 40gb extra space unpartitioned, when I run the linux installer and click something else, it does not show that ... it does not show any partitions ... it shows only 1tb free size (which is the entire hard disk) ... that's the problem. – user236724 Jan 17 '14 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.