I am running windows 7 64 bit on my comp and just installed ubuntu 11.04 64 bit after partitioning the hard drive to give ubuntu 50gb of space.

I used a usb drive to try it out first and then i installed it and it worked perfectly and the asked me if i wanted to restart. I allowed it then it asked me to remove any 'installation media' AKA my usb drive and press enter. I did so but next a black screen came up with no text.

I thought it was part of the installation so i left my comp and came back 15 mins later but it still was at the black screen! I tried typing something, pressing 'esc' and even pressing the power button but nothing happened. Then I pressed the restart button and it restarted and booted into windows 7 with no trace of grub!!!!what am i supposed to do? I'm only a novice.

  • I just experienced the exact same thing. Do you have any good news for me? :) – Drew Noakes May 10 '11 at 2:05
  • I sorted my situation out. Answer below. – Drew Noakes May 10 '11 at 15:17

Are you sure Ubuntu was installed ? If so, then you can recover your grub . Follow the procedure as explained on this post.


In order to view the GRUB menu in 11.04 do the following in terminal

gksudo gedit /etc/default/grub

Comment the following lines


Uncomment this line


Enter the default time for grub menu to display


save the file and run


reboot, you will see the grub menu


I installed 11.04 over the top of a Win7 installation and upon booting never saw a GRUB menu. In my case I just had to reinstall GRUB 2 using instructions from here

Booting into the Ubuntu CD:

sudo fdisk -l


   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sdc2              13       12195    97851877+   7  HPFS/NTFS
/dev/sdc3           12195       15567    27078657    5  Extended
/dev/sdc5           12195       14784    20796416   83  Linux
/dev/sdc6           14785       15567     6281216   82  Linux swap / Solaris

So I am working with /dev/sdc5. If yours is different, substitute throughout the following commands.

Mount it:

sudo mount /dev/sdc5 /mnt

Reinstall GRUB 2. Note that this command doesn't have a number on the end of the volume's path:

sudo grub-install --root-directory=/mnt /dev/sdc


sudo umount /dev/sdc5


sudo reboot

That was all it took for me. Read the full instructions to be sure your case is not different.


Use windows7 "computer administration", "local drives" (I am not familiar with the exact names in w7) to check your partitions - are there partitions for "/" and "swap" (w7 will not label them - they come as "undefined" or "unknown").

If they are there, restart from your USB Device to run ubuntu and check if you can find files in the ubuntu partitions. If they are there, you might have installed the grub menu on the wrong disk. You might find it useful to check this grub2 help page


Do you see a pause when the system is booting, or does it jump straight into Windows?

I have the same problem by the sounds of it. If you're seeing a pause during boot though, it may be that Grub just simply can't display properly. Boot into Ubuntu via the CD ROM that was bundled with it:

gksudo gedit /etc/default/grub

And uncomment this line by removing the leading # character:


Save the file, exit and reboot. Does that help?

Idea taken from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.