I tried to install the nvidia-331 drivers but as usual it doesn't want to work... I get a blank screen when I boot up.

I tried the instructions here Blank screen after installing nvidia restricted driver but that didn't help

I was actually able to load the driver with jockey-text and startx worked, but obviously no unity or any windowing... I started it from recovery mode.

Hopefully someone can help before I have to reinstall the OS again.. sigh

  • try to purge all nvidia drivers by running sudo apt-get purge nvidia*and then reset unity and compiz. Jan 17, 2014 at 4:35
  • The reason the most voted answer at "Blank screen after installing nvidia restricted driver" thread does not work is because it reverts back to xserver-xorg drivers which are default open source drivers. Have commented there to try and get users to improve the existing most voted for answer highlighting that it actually does not answer the question asked. i think/suggest the answers here should be merged to the mentioned thread as this is a duplicate of that thread imo. All ask ubuntu users are encouraged to edit/improve existing answers over providing a new answer.
    – geezanansa
    Jan 31, 2015 at 12:04

2 Answers 2


I had problems with NVIDIA on a MacIntel, blank screen, yada yada. Eventually I ended up installing the kernel source manually, as in




After that it worked.


Please see my post here for a start. After the Failed Installation of a Video Card/Driver Ubuntu 13.04 Displayed a Blank (Black) Screen. There are a variety or reasons for a blank screen, each of which has a different solution.

I see that you have Jockey. For me, Jockey was critical in resolving my blank screen as I was able to use it to assign the Nvidia driver. Under Ubuntu's system settings, for my computer, no proprietary drivers are displayed even-though they are shown as available under Jockey. Furthermore, in my case, the initial re-boot after using Jockey to set the Nvidia driver failed. Taking a leap of faith, I simply re-booted and the screen display worked as expected.

As an additional thought, I suspect (but I have no proof) that the blank screen may result from an Nvidia program associated with (hypothetical) driver XXXX, but is incompatible with driver ZZZZ and was not removed with the purge option for driver XXXX. All that I can say is that aggressively removing all Nvidia programs before using Jockey seemed to help in getting the blank screen problem fixed.

Good Luck. It took me quite a while to get this issue resolved.

Not the answer you're looking for? Browse other questions tagged or ask your own question.