I want a keyboard shortcut to mute my system microphones unless I'm on a conference call or something and WANT it to be on. It wouldn't be ideal - I wish it were system wide with an indicator with a clear icon of whether that hardware is in use (webcams too!), but this keyboard shortcut is an immediate measure.

Unfortunately, this keyboard shortcut (Ctrl+Audio Mute) seems to have no effect. If I run the command from terminal, it works but just not as a keyboard shortcut. If I change the keystroke to something more standard (Ctrl+M) it also doesn't work (my keyboard has an Audio Mute key that this control panel did detect itself). There's no error shown.

In my particular case, I'm using LiveMeeting inside a VirtualBox windows machine. I'm using the basic audio settings, not some special vm-dedicated usb mic - just the standard built in mic.

Whatever the solution, I hope it will take into account all the various microphones! My external webcam has a mic, but I don't use it ever - instead I have a usb mic that I like, and then there's the built-in mic. I want to know that none of them are listening!


enter image description here


Also, if I try to map Ctrl+Audio Mute or Ctrl+M to gnome-calculator it does not work. So for me this appears to be a problem with the keyboard shortcuts generally.

I also notice that my built-in keybindings are not always reliable. Especially scary when I'm in VirtualBox and either the VirtualBox hostkey functionality doesn't work OR the Ctrl+Shift+[arrow] doesn't work to switch workspaces. Haven't made a guess as to which yet - this one seems to happen when I've left the computer idle for some time.

Futher, I've noticed that Alt+Ctrl+T for the Terminal is unreliable (regardless of VirtualBox). Sometimes it works, sometimes nothing happens.

If this normal? Is this just the state of linux/ubuntu/unity at this time and I need to be prepared for these annoyances?

FYI I'm running a System76 machine so all the core hardware is as compatible as it can be, right?

I also tried using Compiz instead but that didn't work either.

  • I have the same problem. Used to have Custom Shortcuts working, they got lost after upgrading from 12.04 to 14.04, and trying to set them up again has failed. – azzid Sep 6 '14 at 13:10

I had this problem and found the answer on the Ubuntu bug report helpful. After switching input method from iBus to xim, and then restarting, global hotkeys worked. To do this, run imconfig then follow the directions, and then restart X11 with sudo restart lightdm (assuming you use the default lightdm).

You should be able to switch back to iBus afterwards, and hotkeys should still work.

  • 1
    On comment 66 of that bug: On CompizConfig Config Manager just disable Commands. No need to restart lightdm on my case. – Pablo A Jun 15 '17 at 2:32
  • 1
    Did you mean im-config rather than imconfig? – Cedric Reichenbach Apr 9 '18 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.